Download

After changing skeleton, montage won't play

Hello,

So no I have created a new montage for the new skeleton, it’s not because the montage is not suitable.

What is going on:
I created a new character mesh with a new skeleton. I replaced my default character mesh&skeleton with a new one.
I created animations for the skeleton, animbp, blendspaces. Walking works good.
The problem is in a custom action performed on a button press.
It was working fine before I changed the skeleton&character. Now it just won’t work. Blueprint fires, things that are supposed to happen after montage happen but animation won’t play.
If I put the animation or montage to a level, they will play. The animations use the skeleton I am currently using
When I replace the character skeleton with an old one, it all works again

Futhermore, animations with new character play when are done via state machine but that’s not what I need

Please help, this is definitely a bug!

Did you check if the play montage node still has a montage selected?

Hello, thank you for your help
Yes, I have checked, I selected it. And have tried creating new montages and selecting them, but nothing would work. Strange…
If I set animation mode to be “asset” instead of animation blueprint, I am able to see the character playing animation with no problems
Maybe I made a mistake somewhere in the new animbp. I have checked it multiple times, it’s fully identical to the old one and doesn’t seem to have a connection to those montages, but who knows
Maybe a system restart will help, sometimes it does.

Maybe the problem is with the montage node. Which one are you using: “Play Anim Montage” or the “Montage Play”. You should use "“Play Anim Montage”.

Hmm I am using Play Anim Montage and it works with another character when I change the skeletal mesh and animbp for it, probably something else
I will try now my problematic character without any animbp at all, will just move it and try to play montage

Yes the problem is with anim bp. I will try to recreate it. Thank you for helping me
upd: I was wrong, anim bp has nothing to do here

Recreated the AnimBP, still the same problem! The h…!
After that, I tried to setting blueprint to none: didn’t help
After that I got back to using animation asset. Didn’t help
Restarted the system - didn’t help
Deleted saved and intermediate folders - didn’t help

Okay, the only way to get it somehow working is using Play Animation node instead of Anim Montage node(I am using the same montages here). But this is not appropriate here. Animation does not return into idle upon completing. Speed of playing should be controlled with a variable as well.
There is definitely something going on in the guts of the engine, someone from Epic pls help

Okay… Now it doesn’t work with my default character… I am starting to freak out

Do you have a “Get Anim Instance” node plugged in to the target of the Anim Montage node? Or are you using the montage node that takes the mesh as the target? There are several different montage nodes, and you definitely want the one that gets called on the Anim Instance.

In fact im almost positive that is whats happening here! Calling Play Animation on the mesh switches it to Anim Asset mode, which is why it sticks at the end of the animation. If you are running an AnimBP you always want to call “Get Anim Instance” on your mesh, and pull off the pin to find the animation node that goes with it.

Hi, thanks for your help, man
No I have never used “Get Anim Instance” node in my project’s history. I have another project where I don’t use that as well and everything works.
Everything was working until I changed the skeleton today. I didn’t change anything else. Now I am back to my regular skeleton and nothing works as well.

Upd
I tried to hook it up into every montage node’s hole, it says it’s not compatible

Now NO MONTAGES WILL WORK AT ALL!!!

Montages won’t work in anymore in any new projects, I have a few versions of Engine, it doesn’t work anymore in any, and it was working today in the morning. I am not crazy. They still work in ONE old project.

HELP!!!

Am I going crazy? Maybe the fact that everything was working is my imagination?

It won’t connect because it’s the wrong node. AnimInstance has it’s own version of the montage node that you need to use, it’s called Montage Play. You also could try using Play Slot Animation as Dynamic Montage, and set it to a slot that you place in your AnimBP.

You have to use the AnimInstance because that is the reference to your AnimBP. If you try to call the animation directly on the mesh, it will fight with the AnimBP since they are trying to override each other. It’s like trying to put two different people in the driver seat of a car.

If that doesn’t fix it, could you post a screenshot of your nodes?

0b41f9f45e8474f0d6617aedfde6f30dbd2ee71b.png

Oh my… Yes, I deleted the default slot, thanks