After building UE5-EA2 from source, editor won't open (missing UnrealEditor.modules file), why?

Hi, this is my first time trying to build UE from source code (I need it to package a dedicated server).

Following are the steps I took:

  1. Downloaded the source code as a ZIP file from here:
  2. Used PowerShell to run Setup.bat with the following options:
    .\Setup.bat -exclude=Linux -exclude=Mac -exclude=Android -exclude=TVOS -exclude=IOS -exclude=GoogleVR -exclude=GoogleTest -exclude=LeapMotion -exclude=Dingo -exclude=Switch
  3. Again from PowerShell executed: ./GenerateProjectFiles.bat
  4. Opened UE5.sln in Visual Studio, set the solution as Development Editor and Win64, then built the UE5 project.
  5. After the build, trying to open …\Engine\Binaries\Win64\UnrealEditor.exe throw the next popup:

The Game has crashed and will close

Fatal error: [File:C:/UnrealEngineSource/UE-5-EA2/Engine/Source/Runtime/Core/Private/Modules/ModuleManager.cpp] [Line: 1035]
Unable to read module manifest from ‘…/…/…/Engine/Binaries/Win64/UnrealEditor.modules’. Module manifests are generated at build time, and must be present to locate modules at runtime.

So, why is it not generating the UnrealEditor.modules file when building the project?
I appreciate your help in advance.

Note: did the whole process 2 times, once using VS 2019, then using VS 2022 with the same results/errors.

1 Like

Hello, did you ever solve this? I have the same problem.

1 Like

Hello, I have the save issue with Meta’s GitHub version of Unreal Engine. I’ve compiled it with Visual Studio 2022 and none of ‘UnrealEditor.modules’ files generated. So it crashes on start. Does anyone know how to solve this?

I think a lot of people are currently having this issue, myself included. I’ve been asking around. I’ll let you know if I figure out a solution or hear anything from anyone else.

1 Like

@derf0007 @Creo I did this almost 2 years ago so I don’t remember all the details, but back then I needed the source build so I could generate a server from it.

I got some notes though and I actually got to build the editor (and opening it without problems) using VS 2019, I followed the same steps I described originally with the only difference this time I ran .\Setup.bat with no arguments (that is without exclusions, so it took more time and disk space being full size).
Note: I also tried this with VS 2022 but while the editor build succeeded, then I got errors when building the solution on my game project.

Anyhow this got a gotcha (at least for me), after setting my game project as Server Built Target (step needed before generating a server) and try to build it, it failed, so at the end I couldn’t generate the server for my game which was what I was looking for.

I’m not currently working with multiplayer (I deleted those files and I will surely try again in the future) but maybe you can give this a go and see if it works for you, I’d love to know!

@Creo For me, I had to open visual studio build the ue5.sln and then hit the play button to debug it and that generated the modules for me.