After building light static mesh turns black

I heard that you have to make a uv map or something but not sure how to do that and also heard that you can turn light map coordinate index to 1 but it just turns to 0 when I type 1 in. I used blender to create the model and exported .fbx.

I was able to create a uv map and it fixed it but theres like black squares on it. Any idea how to fix that?

Kind of hard to see on that screen shot.

I was able to fix an error about smoothing groups by enabling recompute normals, but this gets rid of the smooth setting that I added in blender. now I get a new error about maps overlapping.

The docs should answer all your questions <3

I just decided to give up on that model and try the simpler one and got it working.

I know this is crazy late, but I found what solved that problem was generating a smart UV project by pressing U after all vertices are selected in edit mode. Make sure it has some spacing. Reimport it in UE4 and make sure you click the down arrow in mesh options on the import screen, then unclick “generate UV maps.” After double click the model in UE4 and change the UV channel to the available channel.

Worked great for me