after 4.16 migration, lots of soundcues in sequencer editor had their volume values reset to 1.0

So to give a quick overview, 99% of the sounds in our project are soundcues added through the sequencer editor.

After upgrading from 4.14 to 4.16, I am finding that lots of random individual soundcues had their volume settings reset to 1.0 for no apparent reason (most of these sounds were set somewhere between .2 and .4 so its very obvious which sounds are affected).

We use a lot of layered sub-sequencers which are nested beneath their respective “master level sequencer”, however I cannot seem to figure out what is causing some of these audio regions to have their volumes reset. Some Master sequencer levels are fine, and some have sounds with volumes reset. Some sub-sequences also have the volume change issues, yet some are fine.

Having a lot of trouble tracking this one down and it has caused some crucial audio level mix issues with our project currently and is going to take a lot of days to re-mix all the levels that are lost if I cant figure out this issue.

I just tried this and it worked as I expected, going from 4.13 to 4.17. I created a level sequence with an audio asset in it and set the volume to 0.2. I then opened the project (which copied it) in 4.17 and looked at the volume and it was correctly set to 0.2. Between those versions, there was a change to allow you to key the volume. There is support for backwards compatibility though, which is what I just tested, albeit in different versions that you are in. I also tried asset migration and it worked as well.

Anything you might be doing differently?


Nothing different, other than engine updates to the same project we have been using since 4.14. (upgraded to 4.16 directly from 4.14).

A lot of the soundcue values did seem to carry over properly, though the soundcues reset to 1.0 show no difference in comparing directly with ones who’s volume settings did carry over properly.

I really appreciate the new volume keying feature as I’ve already started using it a bit, however completely separate from these soundcue volume issues I am finding.

So you’re saying that the Sound Volume (Default Value) that I highlighted in the image has the correct value for a lot of the soundcues but not all?

Yes that is correct.

UPDATE: After doing a lot of testing with reverting sequences to previous versions, I have narrowed down the issue and am fully able to reproduce it on my end. It seems to be happening when I save a sequence after making any amount of small audio changes, in this example case adding 2 new Soundcues to the beginning of the sequence. After saving, closing, and reopening, all the other soundcues in the same sequence have their volume settings reset to 1.0. Yikes!!

Here are 2 examples of how I discovered this.

I made some minor audio changes to a sequence last week, added a couple new sounds and deleted a couple old sounds. The new soundcues I added were left with their volume setting at 1.0 I would say there were about 10 new sounds added overall. I saved that sequence and checked it in.

Now, that sequence has all of its soundcue volumes reset to 1.0, 95% of these soundcues I did not touch when I made the minor audio changes.

If I revert back to the previous sequence version before those “minor changes”, the audio volumes are back to their original values as intended.

This also happened yesterday to me with a different sequence, where last night was when I first really noticed it.

Yesterday I spent all day working on adding new footstep soundcues to a sequence before saving and checking in. I listened through the sequence and everything sounded good. So I saved and checked it in.

I then opened UE4 up again and when playing through I could hear something was wrong with the audio in that scene, so I went in and noticed all the soundcue volumes in this sequence were reset to 1.0. So in this case if I were to revert my work yesterday it would remove a day worth of audio work adding the footsteps, but I would have my proper volumes back.

This has turned into a CRITICAL bug for us as we are in the middle of a crucial audio production cycle and until this gets fixed, we am not currently able to save any new sounds to a sequence without resetting all the soundcue volume levels back to their default 1.0 level, essentially destroying all the meticulous sound level mixing work done.

You’re correct. And thank you for the detailed investigation. I was able to quickly reproduce the problem. I’ve fixed the issue and checked in the fix as CL #3578170. The fix will be part of the next 4.17 hotfix (4.17.1). I don’t have a time frame on that, probably a week or so. The related jira is:

I realize you’re on 4.16. Hopefully you are compiling your own source and can apply this patch to it? The fix is just in:


In the constructor, initialize these values to:

AudioDilationFactor_DEPRECATED = FLT_MAX;

Again, thanks for pointing this out and apologies for the troubles it has caused.

Awesome, seriously thank you so much for this fix!!! Amazingly after this patch, all of the original volume values came back and our project is back in top audio shape without having to re-do any serious amount of work.

Thanks again.

Fantastic. Glad to hear it. Good luck with the rest of your project!