Download

Advanced Sessions Plugin

You need to go to Plugins window and enable “OnlineSubsystemSteam” and “OnlineSubsystem”, I am not sure about this one but I think you also need to enable “OnlineFramework”.

Edit:


Thank you so much, it’s working!
Feeling a little bit dumb, but happens. :smiley:

Thanks guys!

Thanks for giving him pictures, was at work when he asked

Okay, now i’ve got another problem, and again, no idea whats going on.
Had to work on 4.11, and thought i can port it to 4.13 like yesterday.

Replaced the Plugins, activated the plugins in the settings, and i can’t package it. 4.11 is working though.


UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: VictoryBPLibrary.generated.cpp
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(16): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(21): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(26): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(31): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(36): error C2007: #define syntax
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: f:\stayclose\413\plugins\advancedsessions\intermediate\build\win64\ue4\inc\advancedsessions\BlueprintDataDefinitions.generated.h(41): error C2007: #define syntax

(…)

Seems weird because there are errors of the victory plugin, too.

e/ okay working now. What i did:

  • Started the 4.11 project with 4.13 to upgrade
  • Failed because Plugins
  • Replaced Plugins with new versions
  • opened project
  • started build
  • enable plugins (as above)
  • started build again
    -> working

before:

  • deleted saved + intermediate folder
  • replaced plugins with newest ones
  • startet upgrade
  • build
    -> failed.

No idea whats going on. But at least it’s working.

Has anyone managed to get Dedicated server working with this plugin?

I have successfully got player user name using this plugin, but after packaging, tha call seems to fail. I have followed the instructions in this page

How can I make sure the plugin has been packaged successfully? Any hints will be helpful.

I am using Steam subsystem btw.

The plugin was made prior to the engine directory addition and i’ve never added “Installed” to it but left it as a manually added plugin for projects. Without changing the installed line and making sure the binaries are built to your version (if an un-updated version) you have to add a blank c++ class and include the plugin in the buildtarget.cs “AdditionalDependancies”.

I generally build all binaries but I don’t know that providing it at an engine plugin is the best idea considering it isn’t a marketplace item and still requires manual installation anyway and being able to recompile it as needed is useful for users.

How can I find all the sessions with steam appid 480?
Because it finds only games that my steam friends created

Thank you for your answer and this great plugin, mordentral.

I have added the “Installed: true” line to the .uplugin file. So I don’t need the c++ file, right?

And how can I make sure the binaries have been built to my version?

Thank you in advance.

If the engine version matches the version that you downloaded you should be good. Otherwise you either need to rebuild engine with it in the engine plugins or move to your project and rebuild the project, at that point it would be easier to leave it at the project level and include it in the build target.

480 is region locked, if you are trying to get sessions outside of whatever the region bounds are then you are out of luck. Also the engine itself auto filters sessions using different builds from returning (you can see it in the log).

Valve doesn’t want 480 to be used as a proxy connection for released games or projects, just a temporary setup id to get programs working with steam, so it is a little limited.

So when I get my appid, I will be able to see all the servers using my appid just by creating the advanced session and then finding it?

Yeah, you have to specifically add region locks to your own App ID.

Hi, mordentral, I’m using 4.12.5 and this plugin to get Steam user name. When launched in standalone mode, it works perfect, but after packaging, Get Player Name node always returns “Player”. I think I have packaged successfully, what anything else may go wrong?

Your steam subsystem isn’t working correctly, make sure you package it out with the project.

You can package in development mode and run the exe with -log to see the log during run.

The subsystems turned into plugins in 4.13 and don’t require as many steps to get working but you still need to declare them in 4.12

Thank you, mordentral. Just like you said, I haven’t packaged steam subsystem correctly according to the log. Didn’t know the -log option.
Now it works well. Thank you.

Is there any tutorial on the voice communication? I can’t seem to figure it out.

Ill check with the -log option too… but, I just posted a question here too:

https://answers.unrealengine.com/questions/507485/steam-online-multiplayer-in-v413.html

There isn’t much to them currently, you add in the ini variables in the OP and StartNetworkedVoice/StopNetworkedVoice if you are using push to talk. Voice has been buggy for a few engine builds now though and while 4.13 appears to have fixed a bunch of it someone reported that with more than a couple of users you still get network saturation (have to increase network saturation limit in engine settings).

You’d be better off not making answerhub posts regarding my plugin, there is no easy way for me to be notified of them and the last few Epic just said “Its a plugin we can’t help you with it” even though they weren’t plugin issues.

You can try with the typical host/find nodes and see if they work but generally your issue is when you don’t have the steam subsystem packaged correctly. You also do not have to manually drop binaries for it in development packages (don’t think for shipping either anymore but haven’t tried specifically in a while).

That’s good to know. I didn’t want to hijack your thread with a long discussion on my own problem. I did check the log file and it originally said it wasn’t initializing Steam correctly. I did a new dev build, dropped in just the steam_appid.txt file and fired it up. Connected right up no issues. Thanks for your help. I cant wait to get into the rest of what this plugin has to offer. Thanks for your work and guidance.