Advanced Glass Shader

If you’re looking for a shader that simulates the kind of glass you find used in sculptures, crystal balls or other solid shapes then look no further. This beautiful shader gives you fine control over parameters such as transmission colour, reflection colour, curvature, refraction, chromatic abberation, opacity, specular and roughness.

Including four common and hideous art glass creations, the Advanced Glass Shader is the perfect addition to archviz, fantasy and sci-fi settings.

This shader is not intended for planar glass surfaces. Please use the default Unreal Engine translucency for objects just as windows. Requires at least one SceneCaptureCube component for reflection/refraction.


Awesome! :cool:

So, are you giving it away? Or selling? Because it looks totally amazing.

Selling! It should be on the marketplace within the next fortnight. :slight_smile:

Looks amazing! Can’t wait to test it out.

Hey guys! It’s been a while since I updated this asset, so a free update is coming your way!

Update 1 will add flawed crystal materials that simulate everything from precious stones to cracked ice:

Look for it next week!

I’m a little bit behind on releasing the update, but here’s another sneak peek:

Here’s a quick selection of some of the things included in the update:

**Flawed Crystal Parameters





Lake Ice



Hey guys! The Flawed Crystal update is finally live.

Time for another update!

Blurred Glass

The new shader consists of a post-process filter and an example glass material. This shader will work with existing glass materials from Unreal Engine, with a few adjustments in the material details.

This shader is appropriate for archviz and gaming applications.

Three post-processing slots are provided for different blur behaviours and includes chromatic aberration for accurate hardened glass simulation such as coffee tables.



  1. Enable “Custom Depth with Stencil” in your project settings
  2. Enable “Render after DoF” and “Custom Depth Writes” in your glass material details
  3. Add post-process material and add “BlurGlassPost” as a material post-processing effect
  4. For the highest quality glass set your glass materials to “Surface forward shading”, but this is optional
  5. Add a normal map to your glass material to match the blur parameters, e.g. frosted glass. This will help with specular behaviour.

Applying in world:

  1. Select your glass objects and check “Render custom depth” under “Render” in the details panel.
  2. Set their “CustomDepth stencil value” to between 1 and 3.
  3. Adjust the values for each stencil in the post-processing material instance as demonstrated in the screenshots above.

This update will be released very shortly!

I’ve just spent an hour trying to load the glass shader into projects that I had it already in there so i could get axcess to the blurred glass and it keeps deleting files I had in there like the map and the mat_glass and nothing in the blurred glass . Tried this on 2 computers in multiple projects - half the time it says it can’t load over some of the assets then the mat_glass dissappears and they no longer work ??? any ideas

projects that do not have it in it and not all loads - no blurred glass no mat_glass no map - ///4.17
deleted off hard drive and aded to project from marketplace as well

That’s unusual.

For the first issue, try deleting the old version of the asset from your project (but keep your presets), then re-inject it into the project from the launcher. If this keeps failing Epic are the ones to talk to as the launcher is rubbish when it comes to deploying assets. The more we complain the faster it’ll get fixed. You could also try injecting them into a new project and then migrating them over to your existing project.

It’s strange that you’re not getting blurred glass on a new project. Are the new glass windows present next to the vases in the overview map? If not then you’re not getting the new content. If they are and they’re just not blurring make sure you’ve followed the steps in the post above this one.

Small update coming shortly: the blur shader wasn’t taking into account distance of the viewer from the glass surface. This is now fixed.

There seems to be a lack of good caustics available in UE right now, so I’ve fixed that. Coming in the next update: caustics.

The effect is decal-based and the update includes adjustable decal material, water surface material and water volume material. It’s best viewed in motion:

It does not work. I opened your example scene and there is no blur as on yours screenshots.

hi! this wont work in my scene although i followed the steps closly, may i check anything that i am doing wrongly?