Adreno 330, Black screen

I tried to start Tappy Chicken on a LG G2 (Adreno 330) and had problems, the first start the application unexpectedly quits after Google Play Games dialog, the second start the application is in black screen but is possible to hear the audio output.

Here is the first and the second log already filtered.

I also tried to start a sample (First person, blueprint, UE-4.7.6, ETC1) and is the same problem of black screen, I do not filtered the log because the problem is probably the same.

Note: I am using Android 5.0.2, AOSP, not LG’s firmware.

Hi ferreirawax,

We have an LG G2 in house and it runs Tappy as expected. We unfortunately do not have any devices at all running AOSP for testing.

It is entirely possible that the AOSP is causing a problem. Do you have another device on which to test? Here is the device driver from LG, if that helps.

I will test with an original firmware and then say the result, my model is the international (D802).

Hi ferrerirawax,

were you able to try this with the original firmware? Thanks!

I tested and worked as expected, but I do not understand why does not work on AOSP since there is no known issues about graphics.

Hi ferreirawax,

I am glad that it is working for you now. I conferred with the Android dev, and as we have no devices running AOSP and have done no internal testing on it we are unable to offer any suggestions as to why it isn’t working. I will see if we can get it added to the ‘unsupported’ list for devices.