Admob Ads not working after 4.20.2 update

Admob ads were working in 4.19.2 but same project in 4.20.2 is not working.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


Thanks … I reported the bug. Hope it gets fixed … no point in improving so much on mobile in 4.20 if Admob doesn’t work …

I have the same problem.
Updated one of my projects to 4.20.2 and deployed it to the Play Store and the ads are no longer working. Unless there is a non documented feature or flag on 4.20 for ads, I don’t know what’s going on. Everything else in my project is working as intended and some even better with the updated engine, except for the ads (both ad banner and ad interstitial).

Yeah man … I am stuck on 4.19.2 … where ads and leaderboard works flawlessly …

Hi, do you have the UE number for the bug report so I can follow it’s resolution? I can’t find it on Unreal Engine Community

Unreal Engine 4.21 is now out and this is still not fixed :confused:

I have the same problem in 4.21, admob ad disappeared.
Tick big delay on start in blueprint.
3 sec back screen after logo on app start
Cyrillic names in audio files no longer supported

I’ve just spent the last 4 days trying to get ads working on 4.20.3. I’ve gone through countless pages on google, videos on youtube etc. and now I’ve found this post and I’m devastated about the amount of wasted time.

Same here was trying to find whats wrong with my ads, leaderboard and in app purchase is working, but ads… using 4.20.3

Same …Unreal Engine 4.21 is now out and this is still not fixed :confused: