Download

ADK Crash Animation new

Iv been working on a few projects in ADK for a few weeks now without any issues. Just the other day I had a report that one of my mods creatures caused my beta tester to crash every time they hit it with arrows. So sure enough I tried to duplicate the bug in ADK test area and sure enough when I hit the NPC with an arrow I crashed. So to pin point the issue I tried several other tests and it turns out that now at anytime I hit any NPC with anything ADK crashes… mind you Im no longer talking about just the NPC I made. This seems to come out of nowhere… i dont recall any odd updates or changes within my computer at all.

If I go in to a fresh ADK area with no mods connected and place any NPC from the primalearth folder into the scene and press “play” the second that it reacts to my attack (recently iv just been punching them but it appears any attack does it) ADK will crash… no mods, fresh install (now) and normal ARK dinos! All of the crash reports are the same both with the NPCs path:

Iv made sure every thing is updated and even went as far as reinstalling ADK. Im at my wits end!
Any and all suggestions will be appreciated!

What about the supporting Frameworks the ADK/UDK use? Have you reinstalled those as well?

The Unreal Engine 4 Editor executable from GitHub, the four files listed under the installation instructions? Yes, I made sure to follow all of the instructions clearly.
The problem happened after using the ADK successfully for over three weeks too… thats the weird part.

Added to my Epic games>arkdevkit>projects>shootergame>binaries>win64:
UE4Editor-ShooterGame.dll ARK Dev Kit v236.0
UE4Editor-ShooterGame.pdb ARK Dev Kit v236.0
UE4Editor-ShooterGameLoadingScreen.dll ARK Dev Kit v236.0
UE4Editor-ShooterGameLoadingScreen.pdb

Did you have a Windows Update overnight?

Have you looked into what you have installed that may auto-update? All it takes is one shared file to change.

No, not that I aware of.

After some testing Im beginning to think that it doesn’t even have anything to do with the creatures animations at all. To duplicate the issue all I have to do is make any NPC go aggro on me and then perform an attack anywhere in any direction, even far away from the NPC that is aggro on me with any type of weapon (other than guns apparently)… the only thing that makes any sense to me is that there could be some sort of residual file that became corrupt that a simple verify doesn’t look at.

Im not techie enough to see what updates I may have had at the time but it does look like adbobe flash was updated around that same day. Unfortunately it would be a difficult thing to tell time wise because I dont usually put myself in the position of attacking the NPCs in the ADK… at least not for weeks.

Also, just to clarify things, this problem is only in ADK and not in the actual ARK game.