Adjust Volume function not working?

Hi, is anybody aware of the Adjust Volume function not working at the moment? I have attached this to an audio component and attempted to change the original volume from 0.1 to 1.0 over a duration of 3 seconds but the volume of the audio component does not change. The Set Volume Multiplier still works as intended - but this immediately adjusts the volume rather than over the desired 3 seconds. Unfortunately I can’t use a Fade In function as this- as far as I understand it - cannot be used for sounds that are already playing.

Can anybody advise? Your help will be greatly appreciated.

1 Like

Sorry I cannot offer any help, I am experiencing this issue as well, hoping to find an answer.

Hi @JoeShorrocks, can you provide some more information about your setup?

Which version of the Engine are you on?

Do you have AudioMixer enabled?

I just tested in 4.23 with AudioMixer on and the function worked as expected.

I’ve also been running into a lot of volume issues in 4.23. The volume multiplier setting under the Details panel in Audio Components does not have any affect on the volume. I’ve also tried adjusting the volume in the actual sound wave, this also has no effect. This has never been an issue for me before 4.23.

Apologies for the (very) late reply on this but I’ve just come across the same problem and think I’ve narrowed down the possible causes…

Firstly, to answer your question I’m using engine version 4.23. With my current project, I’ve tried this with the audio mixer enabled and disabled and am getting the same results. However, I think this may be related to an issue with virtualizing a sound when silent rather than the adjust volume function. I’ve got a sound (a looping, continuous piece of music) attached to an AudioComponent that I adjust to (volume) 0 over 3 seconds using the AdjustVolume function. I then attempt to bring the volume back up to 1.0 over 3 seconds but nothing can be heard. To test whether the same behaviour occurred without reducing the sound to 0 I repeated the setup, but this time reduced the volume in the first AdjustVolume function to 0.1. This worked, and the second AdjustVolume function raised the volume back to 1.0 over 3 seconds as expected.

I double checked that Play when Silent was selected in the virtualization properties of the attached audio clip. I’m guessing this may be the root of the problem but I’ve no idea how to work around this other than not using the sound virtualisation feature at all and instead just working around the issue by reducing the volume to something inaudible such as 0.0001.

Has anybody else experienced similar issues? And more crucially, can anyone please provide a solution? :slight_smile:

Many thanks,


Also experiencing this issue. Setting the volume multiplier seems to do nothing. Using the Adjust Volume function seems to work for the first play of the sound, but if I walk out of range and then back in range of the sound, it stops working altogether. This is in 4.25.

Having the same problem in UE5.


Same issue for me, with UE4 4.25… I am trying to adjust a gravel sound in real time based on the character’s speed, and none of the sound manipulation functions seem to be working. I am doing this in the character blueprint.

I’m having the same issue with Adjust Volume, but I think it might be because I’m using Attenuation/Spatialization. I think Adjust Volume is not intended for audio components using that?

When I changed my BP logic to use Set Volume Multiplier instead, it worked, albeit without the nice lerp.

1 Like

Thanks for that. I was originally using Fade Out and Fade In nodes to affect the music on player death, but didn’t want the music to start from the beginning each time. The Set Volume Multiplier node worked for me and was able to achieve fade using timelines.

For me (UE 5.3.2) the problem appears only when I input a value of 0.0 in the Adjust Volume node (I wanted to mute the music with a nice lerp). Yes, it does go silent, but then if I later wish to make it loud again, it’ll be impossible, as it’s now forever broken. My only workaround was to use a small value like 0.001 instead of 0.0. Apparently a clear 0.0 breaks it for whatever reason… :face_with_diagonal_mouth: BUT here’s another weird twist: if instead of 0.001 you get greedy (like I did) and try to use something much lower (less than or equal to 0.0001), you’ll now face another problem: no, the sound will not be broken like in the 0.0 case, it will still work if you set it to a louder value later, BUT you’ll have the nasty surprise of realizing that your sound is now restarted from the beginning, instead of continuing from where it left off (which 0.001 still manages to handle properly)… :expressionless:

The audio system is completely broken if you ask me…

1 Like