Download

Adding new maps to shooter game

Hi,
I’ve created a new map called DM-Testrange and I want to be able to select it from the shooter game options menu. How do I do that?

goto ShooterMainMenu.cpp and add into these line as i’ve changed on mine


static const FString MapNames] = { TEXT("Spyral_Prime_SG"), TEXT("Dheneb_Capitalis_SG") };
static const FName PackageNames] = { TEXT("Spyral_Prime_SG.umap"), TEXT("Dheneb_Capitalis_SG.umap") };

don’t forget to save and re-compile

Hey

I know the post is old but I just added the map I made to that file and I got the name of the map to appear but it’s not loading. It just sits there in the loading screen and never continues on from that. Does anyone have an idea of what the problem could be? Is there some way I can check if the map I created has a game mode or not? If it doesn’t, could that be the problem?

Thanks

that is posible though normally it will use the default gamemode, if your loading from the shootergame menu like above then also make sure that the map is in the Maps folder along with the other shootergame maps

Hello all,

I’m having the same issue as HadrianHadrian only now I’m on 4.9.2. I’ve added my map to the maps folder and changed the above mentioned lines. Everything seems to have complied and I’m able to see my map name in the menu menu selection, but when I select my map and start the freeforall I hang on the main menu screen. Is this a known issue or am I doing something wrong?

ok i’ve done this umpteen times and it works, do as above, the maps MUST be in the same folder as the other shooter demo maps, make sure when you build your map you have selecter the correct game type for the map

if you have custom gametypes these need to be changed in the ini files

I’m having this exact same issue, has anyone solved it? Map is in the correct folder, it’s displaying correctly in the menu, but loading the map in WindowsNoEditor causes it to freeze up when I select the map. I also tried adding it to DefaultEditor.ini, which is apparently a required step, but that also had no effect. It is the exact same mode as my level.

Geodav, are you building it a certain way or what? Obviously you’re doing something different that none of us are. I was using 4.8.3 here due to some compatibility issues.

Having the same issue. Anyone got this working?

Ok so after some fiddling I got adding a third map to work.
It took some trial and error and I’m still not sure what did the trick exactly but here is what I did.

On top of adding your map the list as mentioned earlier.

Try…
Matching your map name in MapNames to your PackageNames minus the .umap extension

Add to ChunkMapping Array a 3 so its {1,2,3} not just 2.

And in the ShooterMainMenu.h go to EMAP and add your map there as well, just before EMAX.

I did that and now I can load my map as well as the default ones.

glad you got it working, i’ve since moved away from the shooter game see-ing as i can’t code, it’s a great base to start with but you do need to know how to code.

I did All of that but the best it does is reload the loading image and then does nothing, and the worst it does is has the loading icon going and nothing else happens.

I should also mention that it does work when I run it in the editor but not after I build it for development and I don’t know why that would be happening. Any ideas of how I can fix this?

cpp fixes
static const FString MapNames] = { TEXT(“Sanctuary”), TEXT(“Highrise”), TEXT(“Iceman”) };
static const FString JoinMapNames] = { TEXT(“Any”), TEXT(“Sanctuary”), TEXT(“Highrise”), TEXT(“Iceman”) };
static const FName PackageNames] = { TEXT(“Sanctuary.umap”), TEXT(“Highrise.umap”), TEXT(“Iceman.umap”) };
static const int ChunkMapping] = { 1, 2, 3};

header fix as stated above
enum class EMap
{
ESancturary,
EHighRise,
EIceman,
EMax,
};

I did some digging in the Shooter game folder and found out that for some reason it isn’t adding my map to the cooked content, what is up with that? Any Suggestions?

make sure your map is in the map folder, make sure your map has a supported gametype, make sure you add your map the the package list in the ini file

been a while since i did this so no promises

What is the difference between [AllMaps] in the DefaultEditor.ini and the always-include maps list in the packaging settings? Anyone know why are there two different places for this?

Also, I don’t see any references anywhere to the PackageNames array variable that is in ShooterMainMenu.cpp .

Is it a magic variable for packaging, or is it just a left over thing that doesn’t do anything any more?

Where Do I Add This Code