Download

Adding materials to landscape appear black!

Hi guys, I am very new to UE4 and I encountered some problems real fast. What my problem is, is that I am following a tutorial on how to build a landscape. I create a new level and delete the piece of floor on the screen. Then I create a landscape and add the Ground Grass material to the terrain. After I click create the landscape appears black and I don’t know how to fix this. Please help since I enjoy learning UE4 and I don’t want to be set back because of this. Thank you.

Shading issue. just brush a lil over opens.

More Specific

I am very new to this can you please be more specific?

See the last section here: 5. Painting Landscape Materials | Unreal Engine Documentation

Thank you very much. I’ll try this and get back to you!

:slight_smile: This always plagued me when I first started to. Just make sure one of your layers is applied to the entire landscape, then you can paint over it without the black/squares.

I hate to be that guy, but this really is one of the issues that you would find immediately if you searched.

Hey man I searched a lot and seen many tutorials. In the tutorials they just put ground grass as material and it appears green from the beginning.

Can’t seem to figure it out guys please someone a tutorial?

step 1: Select Landscape
step 2: Go to landscape editor in top left menu.
step 3: Go to paint option in landscape editor.
step 4: Scroll down in paint to the layers or material and select it.
step 5: Press drop down arrow next to material and select instance or material layer.
step 6: Paint over black tiling on landscape.

3 Likes

@ Nik1 do this…

Fill your Landscape with one of your textures from the steps outlined by Sananzos. Then navigate back to your terrain texture material, and drag the Material you want to use from the demo/landscape pack. It might go black again, but simply choose another texture (maybe try a couple) and paint anywhere on the map that has the black texture.

Fixed it for me.

That’s what I did, and I got to this thread, and this thread helped me.

3 Likes

thank u so mush, Unreal Document link shows 404 error. i spend half on hour looking for answer

for newbies like me:

i have problem ))
Press ALT+L solved problem

2 Likes

I thank the Lord God for showing me a workaround for this annoying bug. The test landscape painting I did yesterday showed up as solid black. After filing a bug report (it seems this issue has been around since 2015 at least), I discovered that by recreating the landscape material WITHOUT using Material Functions, I was able to see the landscape material again, and all my painting from the previous day was still preserved in the Layer Info assets. Hopefully that issue won’t reappear in the future, but if it does, at least you can know that your painting isn’t lost, even if you can’t see it, and you might just have to re-set up the material without the use of Material Functions to get that invisible data back.

1 Like

Thank you very much for this! I have been days running in circles…

1 Like