Adding component to blueprint is crashing my editor

Hey all,

I have recently installed unreal engine 4 for my class at university and have run into a big problem. When I go into blueprints and make a new class blueprint, that works fine. But the moment I try to add a component, say a cube, it will freeze, and when I try to close the program a white box will appear and I will have to close the program via task manager. It seems that when I click the green box for add component, the title “Adds new component to this actor”, will stay and not go away.

This also happens when I click content browser in the main editor, the title box will not go away and will follow my mouse over any other heading and once I click on a object to add it will crash the editor.

I’m out of ideas; as I have uninstalled the whole engine, re-booted my computer several times and nothing works. Everything else about the editor works fine.

Thanks.

Hi 6rocky2,

While testing I was unable to reproduce your issue. My steps were:

  1. Create a blank project with default settings
  2. Right click in content browser and select blueprint class
  3. Click on Actor when the “Pick Parent Class” dialogue window pops up
  4. Open new Actor BP in BP editor and click green “Add Component” button then select cube

RESULT
Cube is created as a static mesh component

If you followed these steps and are getting a crash I would like to get your dxdiag specs.
You can do this by:

  1. Opening the command prompt and type: dxdiag
  2. Then a window should pop up with your system info.
  3. Click the “save all information” button at the bottom right and attach that information here in a comment.

Click the

Hey Ed,

I tried doing exactly above and it still does not work. It looks like dialogue window does not want to work. It will show up as completely black and I am unable to click anything.

Attatched are my specs that you requested.

I also attatched a screenshot of what happens when I try to follow these steps.

[link text][2]

According to your dxdiag your drivers are out of date on your GeForce GTX 860M card. Get the most up to date driver here: http://www.geforce.com/drivers\

Try this and let me know if this resolves your issue.

Thanks

Ed Burgess

That worked! Thank you man; I really appreciate it.