Adding a function input deletes all used output connections!

This is by far the worst 4.13 bug yet because it deleted logic and broke my whole game!

I added the inputs Use Relative Location Instead and Relative Location to that function I then compiled the function which in result deleted all output connection in all the blueprints! In this case the connection to Snapped Location B.
This is a function library function which I use in a lot of blueprints and now I have to go in and fix them all not to mention that I can’t change any of my many function library functions without breaking all the outputs. Just to give you an idea that this bug should need to get fixed asap.

Hi ,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • What steps can I take to reproduce this on my end?
  • Is the function a custom function or is it a function that you have edited via source/c++?
  • Was this function from 4.12 and only occurred in 4.13 or was this all made in 4.13?
  • What functionality broke when you added the input?

I gave it a try in a new clean project and did not happen there. It is a blueprint function I made in a blueprint function library. I forgot that I also added a local variable as the bug happened. That is a function that was already in it when I worked on it in 4.12, it was also already there when I worked on it in 4.11. As mentioned before what broke is all the output connections in all the blueprints where that function is used. In the case of the screenshot UE4 deleted the connection from the output Snapped Location to the variable Snapped Location B. Well, I certainly will not do any more library functions til I know connections will not just disappear anymore.

Do you have any steps I can take to recreate this on my end?

Hi ,

We have not heard from you in several days. I am marking this as answered for tracking purposes, if you are still experiencing this error, please comment with the requested information.