Adding a blueprint to character socket messes up input axis's?

I have a basic third person style character and i add a blueprint actor to the characters hand socket (a blue print with a mesh in it). Every time i do this though my movement of the character becomes horribly distorted. Pressing forward the character strafes quickly to the side and is soon stuck. As soon as i remover the child blueprint ( parented to the skeletal mesh so it can use the socket) the game movement runs fine again.

Im at a loss how this is happening and i havent come across anyone having a similar issue

attaching a static mesh works okay, but I want to attach the weapon being a skeletal mesh; for animations, sockets etc. Having it in its own blueprint lets me dynamically choose it.

I ve tried using the add skeletal mesh component, but theres no input to allow a varaible to pick the mesh like i can do with a blueprint class. It seems like you can only select the mesh from the details panel

upon further testing / debuging I think i can see the problem clearly , but still no solution…

So to be clear, Im adding a child actor to my character mesh as a child,attached to a socket. Once that child has a blueprint set my forward vector and right vector values essentially get switched, so forward pushes the character left and vice versa

more testing

If the child in the weapons blueprint is a static mesh i get the reversed axis issue.
If the child in the weapons blueprint is a skeletal mesh it seems to work fine

This means it should work for my purposes, but it is still a very odd bug