Added third person features, but can't control character

I was started with a first person project and then decided to make it third person, so I added the third person feature, then added the Third Person Character blueprint to my level. I see character and if I play the level, it uses the idle animation, but my camera uses the original 1st person camera, which I don’t even see in the world outliner, and that camera is controlled by the keyboard and mouse input. How do I switch to the third person camera and control the character with the keyboard?


-make sure to delete the fps character bp from the level
-check if you use the right gamemode in your world settings
-in your project settings you have to check if your axis inputs are still right -> like in the third person template :slight_smile:

I don’t see the FPS Character in the BP level. If I set the world settings to third person game mode, then it spawns a new character and camera, which is controllable and the level uses the spawned character’s camera, but when I quit the level, the spawned character is removed from the scene.

My axis inputs are correct


i got the same thing . I dont have components of my ‘third person blueprint’ in the outliner when i quit the play mode. Game is spawning all the components every time giving new numbers for each next to the name of component in the outliner…
anyone solved this problem?

has anyone solved this issue ? it doesn’t seem a major problem but it would be helpful if we can see the reason behind it.

to sum up: there is no first person or third person character in my world outliner but when i hit the play button game spawns a character based on the game mode i chose. so if i chose third person char. for example, game spawns the tp char. even if it isn’t in my world outliner. any idea ?

Noobie here: I eventually figured out that after clicking in the ThirdPersonCharacter Blueprint, on the Details panel, under section named PAWN I clicked auto possess player and it seemed to start working.


Thank you so much, man. That was right!

1 Like

Legend, thank you! I have had this same issue in Unreal 5.1. I had to make sure the player selected was ‘Player 0’.

1 Like

Answer still relevant with Unreal 5.3.1 - I think the tutorial - building your first level needs updating, as the video shows that the avatar can be controlled out of the box, but I couldn’t move the character without first doing what @th3faceless recommended. Thanks buddy!

Update —
I discovered with a new vanilla “Third person character game” project, when you hit play and the game loads, you have to left click onto the character itself to then gain control of it.
i.e. after hitting play, left click on the third person player avatar and then the WASD keys will control the character.

1 Like

The best solution. Thanks a lot :slight_smile: Literally saved my time.