Added foot ik from AdvancedLocomotionSystem cant lift feet?

I added the foot ik system from the AdvancedLocomotionSystem to my project, the characters postAnimBP runs the trace and everything but the players feet become stuck to the ground unable to be lifted. I even tried using the exact same postAnimBP from ALS however it had the same result. I can vaguely remember having this problem before and am thinking it is something outside the postAnimBP by chance if anyone is familiar with this system and had a similar problem can you advice me on how to fix it thanks :).

I have narrowed it down to something to do with the animations themselves as this only happens with the two bone ik node, I also attempted retargeting animations to the ALS mesh and it gave me the same result :frowning:

1 Like

Although this question is a bit old, some might still find my answer useful.
I have found the following the hard way implementing it myself

The problem occurs with animations that are not animating the IK bones (like the default UE animations).
You’ll either have to change/update your animations to use the IK bones or ‘hack’ the following:

  • Perform a velocity check in the IK BP where you only apply Ik when velocity is 0.
  • Enable/disable IK using animation notifies.

Hope it helps.