Download

Added a firstperson character but game is camera free

Hello everyone,

I got this scene, and i dropped a Firstpersonn Character after i deleted the old one by mistake. Problem is : when i hit the play bouton, i play a free camera and not the 1st person one. How can i solve this ?

Thanks by advance !

ZeNewb

To show you more :

Here is what i have on the screen and my project config : 5ef7fbad6dcbd778c2a629545567c10eee1077cd.png

When i play, it just start as the perspective camera, and it falls, like if the camera was a 1st person. I don’t understand.

Hi!
Check if your Default Pawn Class (Character) is really your 1st person character, not default dummy spectator.
And check your Pawn Class in the World Settings and Game Mode (FirstPersonGameMode) settings as well.

your default pawn class should be the FirstPersonCharacter (thats the right BP used in the default template, with the collision and camera set correctely if you didn’t accidentely edit anything) and the same goes for HUD, there is a the FirstPersonHUD (well I think all it add is a small crossair in the middle of the screen)

Hello Boris Blade ! Could you go in detail please ? Im a graphic artist, and never use anything except materials and 3D objects …

Sylvain_L : Maybe you could explain me how to do this ? Thanks by advance !

Edit : i switched default pawn to First person Chracted, and know i can control the things. but i still don’t spawn as my character

Thanks Sylvain.

What do you mean - “I can control the things but I still don’t spawn as my character”?
Do you able to control 1st person pawn, but cannot see arms trough standard camera view or what?
Or it does spawn in the wrong place?

I spawn at the place i have the camera, i don’t spawn where i placed the character. As i set the arms and gun invible and destroyed the shoot option, i dont know if it the start point that is wrong or anything.

but i can control the movement and jump with the basic controls.

FPS.jpg
Probably your default NetworkPlayerStart takes control of the player character.
Try this: in FirstPersonCharacter Details tab: select Pawn -> Auto Possess Player -> choose “Player 0”
You can delete NetworkPlayerStart if you don’t need it.

wild guess, as you don’t show anything at what you really get vs. what you want:
when you say “my character” do you mean a 3D model you made ? or do you mean a BP characher you made ?

if you just put your 3D model (like a skeletal mesh) into the level, it will just be an other 3D objets in the scene. You need to create the BP logic that take care of it (right clic in content browser>create a BP>character)
then edit that new character with the 3D content to put your skeletal mesh in (add also a camera with a cameraboom, an easy way to have a camera that follow your character )
and build the logical in the event graph (taking the input, and doing something of it, ensuring to play the right animation, etc).

if you just create an empty charachter bp or if you just select the default “character” as you’ve done in your screenshot it won’t do much alone. (look at the first person character BP to get an idea of what you need to create to manage the input, anim)

if you have never done that, youtube has lot of tutorial on all the basic things required.

then for the spawning, there are multiple way of doing it.
One is to place a player start (the small flag with a gamepad icon) into the scene and setting the default pawn to your player character.
else you can do it through BP (you can make player take control of any pawn/character in the level; or even just spawn a new one and give player control of it)
edit: as @BorisBlade write, there is also the auto posses method :stuck_out_tongue:

Thanks BorisBlade ! You just save me ! :smiley:

I love this comunity ! You guys are awesome !

Tha

Thank you, resolved :slight_smile: