Add Static Mesh Component aren't visible

i generated a script to generate cubes in front of the character when it overlaps with a triggercapsule. I generated that script in the level BP and it worked fine, but now i transferred it to the triggercapsule BP and i cant get it to work anymore. The cubes just don’t show up anymore, even though my character collides with them (meaning the are in the right spot). I use the exact same settings in the AddStaticMeshComponent Node (Visibility=On, ActorHidden=OFF). Do you guys have any clue why my static meshes wont show up? I hope you can help me.

Can you show the BP?

Sure, np. As i said, the algorithm worked perfectly fine in the level BP and the only thing im missing is the visibility of the static meshes in the other BP.

So I see you adding the mesh, but I don’t see you setting the mesh itself. How does it know which mesh to use ( and which material ).

It’s an option in the AddStaticMeshComponent:

Has anybody else experienced this problem or am i doing something wrong?

Try to add a static mesh component at the BP trigger location, just to see if it works. The BP is too overcomplicated and perhaps it’s something unexpected.

I tried it with your BP (even made a completly new First-Person project) and still nothing. I get collisions from a cube in the center, but i can’t see it. I’m close to thinking that this is a bug.

Ah, sorry, couldn’t see that :slight_smile:

Announcing it’s a bug I find is always a surefire way of finding the mistake you made…

Haha, i will ask politely if it’s bug ^^ Thanks for your help guys, i appreciate it :slight_smile: