Add movement input wrong direction

I’ve got a horse that the character can mount, i do this with “possess”. when i press forward or backwards the horse goes back and to the left a bit, i can rotate the horse but it will still always go back and to the left.

i’m sending out a line trace on the event tick to see that i have the correct forward vector and it seems like i do.
i’ve tried a few different methods of getting a forward vector which have all line traced correctly.

do you mean like this?
if so, this is what i had originally but it had the same result. i’ve been looking online and a few examples where people had it working were doing it the other way so i was giving it a try.

i’ve switched out actor rotation for control ration but the result is the same.

here’s everything from the horse
part 1

and part 2

Why are you getting a forward vector based off the Z axis rotation? Just get the horse mesh and drag off a wire and ask for the forward vector of the mesh. That should be what you want. The line trace doesn’t look like how I would expect if you really had the forward vector. It should go straight out not up. You have created basically an “up” vector which if you wanted that just ask for the Up Vector instead of trying to create it like you are.

I think your problem is using “actor” rotation not “control” rotation. Here is an example from the third person template. And a line trace I did based off this, notice it stays in the forward plane not the Z axis.

Screen shot the entire pawn BP including details panel and hierarchy stuff, it is too hard to trouble shoot movement from the minimal images.