Add Instance, Instance Transform is invalid?

I am trying to evaluate static mesh instances. I just want to spawn some instances via blueprint. I created an actor with an Instanced Static Mesh component, and created a function that should call the Add Instance node. I also created an array of transforms (with 10 entries) to use for each add instance. When I hit compile, I get an error because the Instance Transform pin is invalid, even though I’ve attached it to a ref from the array. It also doesn’t highlight the node with the error (by putting a red flag at the bottom) for some reason. Can someone help me with this?

Try “Get (a copy)” instead of “Get (a ref)”

Same error. It expects a reference anyway.

Didn’t work, same error. Even with the pins split, it still complains “The current value of the ’ Instance Transform ’ pin is invalid: ‘Instance Transform’ must have an input wired into it (“by ref” params expect a valid input to operate on).”

Hmm yeah that’s weird, sorry couldn’t be more help, the only other thing is deleting the variable and remaking it sometimes that works for me. Good luck

Delete the blueprint and start again. I just repro’d your bp and it compiles fine on 4.20 with a ref and with a copy…

Well put up and image of the split stuct pin with the 0,0,0 in everything, just to satisfy my curiosity would you.
Because the error really is because, NULL, is the default of those values, that is the real error. and NULL isn’t a pointer, (nullptr is)

I deleted it and re-created it and it works now. Thanks! Wtf.

That happens… If your editor ever crashes, and the thing you were working on starts acting wierd it is most likely corrupt.

There is really no way to fix a blueprint or a level once its had its brains bashed out.