Add game in gooplay play

i create game for android(and i very big noob with setings in UE4)
when i load game in play. i have error
“upload failed
You uploaded a debuggable APK. For security reasons you need to disable debugging
before it can be published in Play. Learn more about debuggable APKs.
You uploaded an APK that was signed in debug mode. You need to sign your APK in release mode.
Learn more about signing.”

i look in proposed link. and don’t understend when i add this in UE4. can u help how remove this errors ?
googple play give me this link


Hey AlukardX,

Please review the following documentation in order to learn more about packaging and Android APK signing.

  • [Packaging Projects Documentation][1]
  • [Android Quick Start Documentation][2]

Double check the Packaging section within Project Settings. You want to make sure that you’re building your project for Shipping too.

Packaging Unreal Engine Projects | Unreal Engine 5.1 Documentation
[2]: Setting Up Unreal Engine Projects for Android Development | Unreal Engine 5.1 Documentation

ty. i read this. My game work on android. But when i add in gogle play thry write error

Did you set up your Android SPK Signing to be set for distribution? Did you change your packaging settings from debugging to Shipping? If you’re packaging your project out and the debugging option is still set, it’s not going to work according to the message you previously provided.

I create key. add in project all info key store key alias etc. enable in packaging full rebuild and for Distribution. buil project and i have errors.

okay, i noob=) i look on log errors and understand my fail.
i’m glad =)
now all work. ty