Add Controller Yaw Input doesn't seem to do anything

It seemed Set World Rotation had 1 frame delay when I tried to rotate an object with the character. So I’m making the object a pawn and rotate it directly through Axis Input. (Please correct me if I’m wrong with this.)

Problem is Add Controller Yaw Input doesn’t seem to add anything. Control Rotation remain unchanged (See picture. I’m adding 0.9 to Yaw every tick).

It works when I use PlayerController0 to possess the pawn, but not PlayerController1. It’s not mouse input because I’m adding a fixed value to Yaw(or pitch) which doesn’t work either.


EDIT: I ended up taking input from elsewhere through an interface and feed that into an Add Rotation node which weirdly worked without the 1-frame delay. (I had tried something similar which failed before)
I still would like to know more about the problem, any help is appreciated!

Maybe the Yaw value is “overrided” by the mouse position, there is a checkbox, checked by default, where the pawn matches the controller rotation.

Do you mean this? Checking/unchecking doesn’t make a difference…


If that were the case, rotation for Controller should have actual value, which is not true.

Sorry I didn’t saw that you want 2 local player controllers.

I see!,thanks for your method and idea,I alwals don’t know “Add Controller Yaw/Pitch input” What is direct.In General,Default Camera is setted. So if we change Pawn of setting,Let Third Character’s Pawn is setted , we can solute this question!