Add Actor Yaw Rotation not working

Hello, I am making a player camera, however, I have stumbled into a roadblock. The component “Add Actor Local Rotation” is not working when trying to rotate the entire actor on the Z-axis with input from the mouse x axis. I have also tried using “Add Actor World Rotation.” It works well when rotating on the X and Y axis, but not the Z. If anyone is able to help, that’d be appreciated.


The Blueprint

It works fine for me, what’s the problem?

It simply won’t allow me to move my character on the Z-axis

I have uploaded a video for you to see.

Probably in the Player Controller

I don’t remember what is the correct setup, anyway it has to do with “control rotation” and there are 3 check boxes for XYZ rotations

Play around with them and you’ll solve your issue

1 Like

I looked inside a character I made that works in a similar way. I have

image

2 Likes

I meant this
image

but my bad I said it’s in Player Controller - that’s setup of the Spring Arm

I know, but there’s no spring arm here, it’s FP :slight_smile:

True…

that’s weird

I would make a Print String to check if there’s any value comming through
Also testing on a fresh Project is always good to do

If you don’t override the rotation anywhere else then it should work as intended

What if you manually type some value instead of getting the Mouse X? But also check the value you get from the Axis Mapping

Maybe in Project Settings → Input the scaling value for mouse X is set to 0 or nothing is specified for the button/axis?
image

This was the solution!

1 Like

Glad to hear that! :slight_smile:

I share update UE 5.2, YAW it must is desactive.

5 Likes