Add Actor World Transform + Jump = clipping

Hi Everyone, I have a setup for a “slide” for my character, kinda like a quick way to dodge through spacing (sort of a fighting game). It uses the add actor world transform. (though I’m not sure this is the best node). Anyways, the slide is oriented at the control rotation, and if I do it with the camera facing a little bit downwards, and I jump during it, as long as he’s still traveling upwards if I do the slide downwards plus a direction, the character while slip right through the floor of the level. I’ve tried setting the collisions for the character and capsule component to blockall as a test, but it did not work. Anyone have any idea as to what I could do? Thanks!

As a side question (I planned to make a separate post but I’ll try this instead) When I turn off use pawn control rotation to fly in my game, but I turn it back on to walk, if I turned the camera’s yaw at any point, it’ll reorient it back to what the yaw equaled when I turned off the pawn control rotation. I can have the camera set back to what it was right before I turned it back on, but it’ll jerk hard after trying to reorient between the two rotations. Any ideas for this one? Thanks again!

I should add after more testing it pretty much just clips regardless of jump into walls. I’m guessing a world transform takes priority over any collision or something like that? I’ve tried some other options but can’t find any that work as well as a slide.