Download

adb doesn't show my device can you help

I know this isn’t a UE4 problem but i’m hoping for some help some you guys

i’ve installed the tadp , my computer see’s the tablet now (as media device) usb debugging active,

but the adb doesn’t see the device, afaik all the var’s are set correctly, not sure where to go from here, looked at a few tips on the net but nothing seems to work
the manufacturer says to use the default android usb drives

any help would be most grateful

I had this problem too. Essentially the phone/tablet must show a popup window asking for permission to allow certificates for your computer. With your phone plugged in and adb ready, try disabling developer mode and enabling it again on the phone/tablet. After a few seconds you should see the popup that asks you to allow the PC. Make sure to check that it should remember your choice.

If this does not happen, make sure you install the driver package from your phone/tablet provider. LG has a separate download for the usb drivers while Samsung needs the Samsung Kies client. If you use Kies, download it. Get latest update. Then in Kies, in one of the menus, reinstall the USB driver. Then uninstall Kies.

Should be enough to get your PC recognized on the phone/tablet, which in turn allows you to communicate with the device.

Was the device attached when you did the TADP install and have you unplugged it and plugged it back in since? I’ve found that I have to do that in order to get it to show up.

And I assume dev mode is active on the device in question? :slight_smile:

ok it’s a “microstar” tablet eg just the brand name from “medion” but built by lenovo.
here a pic of what i get when i plug it in.
afaik dev mode is active with usb debugging switched on

sorry my windows is in german as i live here.

If you open up device manager what drivers/devices do you have associated with the tablet?
(I’m on Win8 so it’s probably not the same but I have an ‘Android Device’ with ‘Android Composite ADB interface’ under it for my Nexus7)

hi bob i think thats part of the problem, all the internet shows are with (‘Android Device’ with ‘Android Composite ADB interface’)
mine doesn’t show Android Device , to be honest i’ve no idea what to do next

I would double check it is using the correct drivers currently, and if not try forcing it to (uninstall, then on the unknown device try installing and pointing it at the drivers you have) - I’ve not used that brand so I don’t know what driver you’d need however, could be it needs a specific type.

change the usb from camera to ptp in the drop down menu when you connect your phone where the usb option comes up on the phone when connected to pc

You need the proper USB driver that works with adb.

For some devices the google provided USB driver that comes with the SDK things works, for other you need a specific driver.

If you had that installed and you had overseen the confirmation dialogue on the device adb would tell you that. I dont know where you can get the driver for your device.

sorry i should have got back on this the problem was the driver wasn’t done right as most tutorials leave out some important facts about the “Android Composite ADB Interface” i found this one which help/solved my problem

btw i made a quick test with the 3rd person template but something must have went wrong as the map was flat !!! , not impressed so far but i’ll stick at it