Actors that are created from the actor component are no longer replicated

You could try rebuilding from scratch. The easiest way to do that is to go to (File->Package Project->Zip Up Project) in the editor and create a zip of your project. Then extract the zip and build that copy. If you still have the problem then you will need to provide more information. There’s no way to tell what the problem could be from your description.

One note: when you build from scratch, try to go back to the last version of your project that you know worked before. Don’t use any version since you messed with it (i.e. the one where you tried creating new actors and components).

Hello everybody!

I create an actor on server side from the actor component. This actor who must also replicate to clients, and he did it successfully.
After updating a lot of content, it stopped working. The created actors on the server are no longer displayed on the clients.

Is it possible to fix it without creating a new project?

PS1. all actors that are created from the actor component are no longer replicated.

PS2. creation of new actors and new actor components did not solve the problem

Oh good. I was getting on to reply to your comment that it hadn’t helped. Good luck with the rewrite!

Thank you. Did not help.

  1. Create replicated actor
  2. Create replicated component
  3. Add created component in some actor (e.g. TPCharacterBP)
  4. In created component begin play: spawn created actor and add it to replicated reference variable
    That’s all.

In my project spawned actor not replicated on the clients. In other projects it replicated successfully.

Now it works on new actors. Thank you. It looks like Zip Up helped.

I will rewrite the actors

I don’t know why that would happen. Is the game mode set correctly? Can you try copying everything over to a new level – see if that helps?

The problem has remained and it is only on one level. On the remaining levels, everything replicates successfully.

I do not know what kind of ■■■■ it is))

I rolled back the revision from the repository and set up the newly restored level. Now, replication works on it.

Cool. Hope that’s the end of it. :wink: