Actors spawning in packaged game bug


So I have a bit of a strange bug in my Win64 Shipping build. When the game tries to spawn an actor using the spawn actor from class node, a reference is returned and I can print the display name to the screen, but the actor does not appear, and logging in the construction script and Begin Play event does not appear either:


However, if I place the actor in the map directly, it at least appears.

I’m not sure what the problem is, and I realise there’s not much to go on here, so if anyone has any ideas, speak up, and if you need more information, let me know what I can do to get it to you! Thanks peeps.

Hi ,

Does this occur with a clean, blank project with no additional content or is it limited to a specific project/actor? Additionally, do these actors appear in PIE or do they experience the same error?

Hi ,

I’ve tried this in a blank project with just some test blueprints which were mostly empty, and they seemed to spawn just fine. The issue seems to occur with specific actors, two that I know about so far that share a common inheritance ancestor. There may well be others but it’s difficult to progress in the game currently - I can try and set something up to check out other actors that also share that root ancestor (or not) if that would be helpful?

Also, these actors do indeed work fine in PIE.

I think that would definitely be beneficial at this point.

Alrighty, so I found the problem with one of the actors. This actor is spawned first thing in the level blueprint, via a manager kept on the player. However, in the packaged version of the game, the manager is invalid at the time of spawn - this is not true in PIE. For reference, the manager is created in the player BeginPlay event. Perhaps this is a bug since it seems the order of player BeginPlay and level beginPlay is not the same in PIE as in packaged? Either way, the fix for me is to spawn this actor later, when I am certain the manager has been created.

The second actor is giving me much more trouble, since it is spawned when the player presses a button (so not subject to the above). This is the actor which the logging in my opening post is about. I am unsure how to proceed with debugging this particular problem. If you’d like to see for yourself, I can link the packaged game on dropbox, or a of the project for you to package yourself and see. Alternatively (or additionally) if you can recommend any further debugging steps, I’ll try them out.

For reference, this problem occurs on the DebugGame, Development and Shipping Win64 packaged games (before I could only test the Shipping build due to crashes in the other two), and on 4.8.1.

Edit: And to answer your suggestion, it loooks like it is this specific actor. I have not come across any others that do not spawn correctly.

Hey ,

I’ll be happy to take a look at the project if you want to send it to me. I haven’t been able to reproduce this on my end at all.

Here’s a link to the compressed project. Should pretty much work out of the bag, except to PIE for some reason you need to recompile a blueprint (might even be the one that’'s not showing up come to think of it).

To see the difference, just PIE, click New Game at the menu, wait a bit, then click on the orange circle at the centre of the screen, and the hammer icon thereafter. You should see a new rectangular actor appear around the edge of the circle. If you do the same in the packaged game, no actor appears.

Let me know if that works for you, or if I cocked it up somehow.


Hi ,

I was able to reproduce this on my end and have entered a bug report, UE-18062, to be assessed by the development staff.

Hi there, just wondering if this bug was ever fixed? I am having the exact same issue in UE5.1