Download

Actors Keep Disappearing...

Hey Everybody i keep getting the weirdest thing happen to me when.

OK I have two actors in my (world/Level) and the Editor shows that they are in my Level and even when i Press play they show up in the Level but when i die and press my Retry button to reload the level those two Actors are not there
anymore, they disappear from the Level and the Outliner. and i don’t have anything connected to them to make them destroy themselves. but when i close out to the Editor they show up again.

So if anybody has experienced this before please let me know…

Odd. Sounds like when you die, you may be loading a different level. Is that something that’s possible?

How exactly are you reloading the level?

Simple… I just have a Button Labeled Retry that just Reloads the same Level when the player dies…

retry.JPG

That’s it…

i was thinking about deleting them and replacing them back into the level to see if maybe that would work. I’ll be sure to update this Thread if i figure it out so that just in case somebody else down the road comes across this problem.

Maybe you just havent saved the level before loading them? Or the editor is bugging out and loading a previous version without them?

yea i don’t know guys… i can’t seem to figure this out i’ve tried deleting the actors and replacing them back in the editor but that didn’t work, I’ve deleted my retry button and made a new one and a couple other little things and still no result. if anybody can think of anything else i’ll be happy to try it.

Where is your level within your hierarchy?

Are you actors up enough above the ground (in case they’re subject to gravity)?

Add an event “End Play” to the actors being destroyed and print the “end play reason”.

Is this multiplayer?

Try the same thing on a blank level.

Did you try in standalone mode? How does it behave?

When you reload your level, can you still see the actors within your scene hierarchy (being alive)?

OK everybody it was the simplest thing… Lol. Apparently all i had to do is re-save the entire Level ( File then “Save-As”) and then delete the old Open Level and put in a new open level and then i tried it. and it worked.

So yea! Thank You guys for your Input…

It is weird tho? why it didn’t carry everything over even when i do just a regular save?