Download

actor (sphere) disappears after being shot

I’m a complete newbie to Unreal Engine and I’m still teaching myself via tutorials and the documentation. I have a sphere using gravity which you can see drops at the start of the level. I can shoot the ball and it reacts to the shots, but many times I’ll shoot it and it will fly off very fast and I no longer see it. The windows (I’ve checked) are solid, so I don’t know where it could be going. Of posts I’ve read, I’ve seen suggestions objects can be auto destroyed if they’re below a particular placement on the map, I’m just stumped here, any pointers would be much appreciated. I have video but can’t share as I’m new. To describe it, I shoot the sphere, it rolls around, I shoot again and it flies upward and disappears but I have no idea where it’s gone or if it has been destroyed.

1 Like

Either decrease the strength of the shot or increase the mass of the ball.

To debug where the ball is going, print the position of the ball to the screen.

1 Like

thanks so much for the suggestion - I thought I’d already tried changing the mass of the sphere.
I set it to around 700kg and now it seems to be responding as it should. Next challenge is to stop it from going through the couch, I’ll see if I can figure that out myself.

Thanks again , very much appreciated :slight_smile:

You can have a look here if physically simulated bodies whose mass differs by orders of magnitude interpenetrate incorrectly:

https://answers.unrealengine.com/questions/1016001/is-there-a-way-to-mitigate-penetration-of-heavy-ob.html

Perhaps that’s of some use.

1 Like

thanks for the suggestion - I’ve had a quick look and doesn’t seem to solve the issue.
I did some A/B testing, if I use a chair (from the starter content) in the same place as the couch, it behaves correctly, no parameters changed - it blocks the ball. If I delete the chair and add a new couch in (again from the starter content), without adjusting parameters, the ball goes through the couch. So I’m wondering if there’s something different in the properties of the chair to the couch, maybe at blueprint level, which is causing this, rather than something I’ve set. I’m going to compare the parameters between chair and couch to see if anything by default is set differently, which may give me some clues. I’ll let you know if I find anything, thank you for the suggestion, I’ll go back to it if nothing else comes up :slight_smile:

ok did some searching about the couch, seems you have to set the mesh to a ‘blocking volume’ - did some testing and that seems to have fixed the issue, with a blocking volume, the ball no longer goes through the couch :slight_smile:

1 Like

When you said

I was under the impression it bounced weirdly or penetrated. But, judging by your description, it seems there is simply no collision whatsoever. Could you confirm the actors just overlap without colliding at all?

In which case it might be a matter of adjusting collision settings on both meshes. For now, just to get it to work, try setting both to BlockAllDynamic; after selecting the Static Mesh Component, in the detail panel:

1 Like

Aye, I was too late.

yeah it wasn’t just a strangeness, it was literally just rolling through the couch as if it wasn’t there. After generating an unmodified couch, same behaviour. If I set the couch to a blocking volume (it’s confusing because under the mesh, it shows in the drop down ‘create blocking volume’) then it just works. I’ll check the chair, maybe it has a blocking volume set by default, I’ve not touched any collision settings. Thing is, I like to be sure of what was causing the issue, rather than something making things work - as I’ll likely come up against it again. So I’ll check the chair properties and I’ll also try your suggestion, as that may be the ‘cause’ and maybe the correct solution to the issue, I’ll let you know :slight_smile:

both are set to using a default value for collisions - yet when I look at the couch and chair meshes (double clicking) I can see collision is set to block all, so I’m still not really sure why both objects behave differently if you leave the collision settings the same when creating the object. I’ll keep looking, the reason is there somewhere :slight_smile: