Download

Actor mesh blinking when camera moves

I see that the animated character player is blinking when camera moves in some particular angles, even in the editor, I’ve tried everything but the only thing that seems to fix it is I set “Render Static” in the optimization mesh.
But doing this I’m scared that I cannot animate it anymore
so how can I fix it please?

Only thing I can think of that causes a similar effect is transmission.
if thats the case, turn it off in the directional light and it should stop blinking.

Hello,
the problem is that I’m using the sunlight system, I cant turn it off… and it produces the same effetcs even in the editor,
if I set “render static” in the mesh, it stop blinking, but can I keep this option on without problem in animation?

No idea. But you can definitely disable transmission either via the light settings or via engine settings, or via material (disable the subsurface profile).

I dont know how to do that, bu I wanna try.
However I think that the problem is concerning the animation Everything started once I’ve imported the FBX with a deformed skeleton scale. I’ve just reset the skeleton via Blueprint

Because it’s flickering only in some certains camera position, even on the editor