Download

Action RPG Epic not working in 4.24

Action RPG which is Epic’s kickstart for mobile game developement.
Works great and exports to Android with no errors in 4.21.
Installed 4.24. Action RPG will not successfully Launch to mobile.
My old projects successfully launch in 4.24. New projects work fine. But if I redownload a vanilla project of Action RPG it will not work.

I feel it’s epic’s project since it’s the only one not able to launch to android successfully.

Error in log is as shown.

LogPlayLevel: [123/127] RPGGameplayAbility.gen.cpp [armv7-es2]
LogPlayLevel: [124/127] ActionRPG-x64-es2.so
LogPlayLevel: Error: F:/UNREAL/ActionRPG424/Source/ActionRPG/Private/Abilities/RPGAbilitySystemComponent.cpp:8: error: undefined reference to ‘FObjectInitializer::Get()’
LogPlayLevel: Error: F:/UNREAL/ActionRPG424/Source/ActionRPG/Private/Abilities/RPGAbilitySystemComponent.cpp:8: error: undefined reference to ‘UAbilitySystemComponent::UAbilitySystemComponent(FObjectInitializer const&)’
LogPlayLevel: Error: F:/UNREAL/ActionRPG424/Source/ActionRPG/Private/Abilities/RPGAbilitySystemComponent.cpp:13: error: undefined reference to ‘UAbilitySystemComponent::GetActivatableGameplayAbilitySpecsByAllMatchingTags(FGameplayTagContainer const&, TArray<FGameplayAbilitySpec*, TSizedDefaultAllocator<32> >&, bool) const’
LogPlayLevel: Error: F:/UNREAL\UE_4.24\Engine\Source\Runtime\Core\Public\Containers/ContainerAllocationPolicies.h:399: error: undefined reference to ‘FMemory::Free(void*)’
LogPlayL

The LogPlayerLevel errors continue a bunch but you get the idea.

Is this a known problem? I am wasting so much time trying to figure this out.
Things I’ve tried.

-Reinstalled UE 4.24. Even to 4.24.3. Even tried it in 4.25 betta with failures.
-Redownloaded ActionRPG project from epicgames.
-Reinstalled the CodeWorksforAndroid-1R7u1-windows.exe

I think you use the AMD cpu.
I got the same error message.
So I tried to build UE4 source but I got another build error about ISPC!
And after solving the problem, I was able to pack the ActionRPG.

How to solve the ISPC

  1. Open IntelISPC.Build.cs file 13 Line
    PublicDefinitions.Add(“INTEL_ISPC=0”);
  2. run GenerateProjectFiles.bat
  3. build Engine
    Have a good day~

I was able to build it on ubuntu 19.04 and launch on mobilephone, but dont ask me :wink: , how much files i have relinkt and how much dynamic libs were missing.
I have new PC with ubuntu 19.10 i can launch it easily in editor … only files to relink was libncurses from version 6 on 5, you can easily mak symbolic links from newer version to older version.

No i have a intel cpu. Are you saying you could get the action RPG to work?

Not sure if same issue but basically I get to 45% load freeze up when I try to start up a new ActionRPG project

So this 45% load issue has almost always related to configuration of DefaultEngine.ini within \Unreal Projects\ActionRPG\Config

So in there I narrowed it down to r.DBuffer=False

If I change this to r.DBuffer=True it loads passed the 45% load freeze

Literally just had this problem, thank you so much!