Download

Action Mappins totally bugged

I have exactly 2 Action Mappings

PrimaryFire which is bound to Left Mouse Button (this is an auto fire, using the release feature)

SecondaryFire which is bound to Right Mouse Button (this is really a single shot fire atm)

I cannot fire my primary unless i am HOLDING the secondary
I cannot fire my secondary unless I am HOLDING my Primary

If I rebind InputAction PrimaryFire to LeftMouseButton…I get the same result
If I rebind InputAction SecondaryFire to RightMouseButton…I get the same result

If I bind SpaceBar to where primaryfire logic was…it works perfectly as desired.
If I bind Q to where secondaryfire logic was…it works perfectly as desired

basically it works on any key but where its set to in the action mappings of Project Settings.

WTF right?

Your project is mobile, change hardware target

no, wrong

It’s desktop/console as desired.

Still stuck on this and my other thread, where i lose WASD and shooting entiurely after respawning and possessing the character.

In my opinion these 2 topics are directly related and seem to be a massive bug. https://forums.unrealengine.com/showthread.php?130989-TwinStick-strange-errors-no-input-after-respawn&p=636230#post636230

Moderator assistance would be fantastic.

Hey!
Can you show your Input Action setup, these Action events and your “Fire” functions?

Sure thing mate. I sort of have the impression this is related to what you said in my other thread about not reseting the “AndyCharacter” reference but who knows. I scrunched up my code to fit into the pics.

The input binds
ce0f6d982239fbc9d101152af4fa09a2a1af77aa.jpeg

The WASD and mouse rotation code inside the Andy_Controller (not the default player controller)
6ed94b8c46461b1b22369cacda9f1aea0b8be95d.jpeg

The binds in my AndyCharacter blueprint for primary and secondary Fire (these were in my controller and are here now for testing)(ignore that secondary fire calling for “fires” that was a test screenshot)
22bcf7a4c1c44eee7c77d02445d7241588068f7a.jpeg

The Primary Fire Function (In AndyCharacter)
a_Primaryfire.jpg

The Secondary Fire Function (In AndyCharacter)
26d9d738399fe1f5abb202d6de6752b4285ef4a7.jpeg

I think the entire problem revolves around my REF to AndyCharacter everywhere. It works perfectly in the mouse rotation, but nowhere else.

I seriously appreciate you taking a closer look at both of these issues :smiley:

Is it because my “AndyCharacter” object reference is not public so it can be refreshed automatically?

Of course now that I have reverted to disable input, hideactoringame,disable collision, fade out…kill enemies, teleport player…unhideactoringame, enable collision, fade in enable input…the event begin play will only fire once right?

The problem lays in the future when I am teleporting the player to other levels not sure what sort of repercussions this aspect will have far down the road because I have so little experience.

Here is how i am storing my AndyCharacter in my AndyController for reference to use with possible other future code:

Notice the REF is not public…does that matter?