Account not working

Did anyone else from overseas who was in the founders club have issues getting their account activated? I am having a heck of a time getting this to work. Maybe it’s because of where I live, Asia, but I can download all of the example content so that must not matter. Anyone have any ideas what could be going on. Right now I am just grabbing at straws to try and fix this as Billing does not seem to know what is going on as well.

Samsterdam, can you describe for me the problem you are having with account activation? There should be no difference between US and overseas with respect to the founders club, but if there is a problem, we’d like to fix it. At what point are you getting stuck?

I am trying something now that was linked to me by billing to fix the problem, but my problem is very simple. I can run the .exe and download the sample content but I can not actually start the editor.

It also takes the launcher a really long time to load, almost like it’s trying to contact something but it’s not getting an answer back. Yeah so it just failed for the second time, but I can retry now thanks to the suggestion in the link from billing. Any ideas on what I can do to fix this?

Actually what Billing gave me looks like it worked. Will post back if there are any more isssue.

Happy to hear this worked for you. It sounds like this was one of our known issues for which a fix was already in the works for. :slight_smile: