Download

"Accessed None Trying to Read Property" Error After Timeline

Hi,
as a new user I cannot figure out why when I use a timeline the AdjustSpringArm throws runtime errors the second time I enter the trigger volume. I’d like to use the timeline to smooth the transition but I cannot put it in a function… Any help?

This is what’s inside. But again, if I skip the Timeline no problem. I can enter the volume as many times as I want without errors.

The Timeline is a simple float interpolation from 0 to 1 that I use as to blend the camera pitch and distance. The cast is on the player 0 pawn, which should always be present, as well as its components.

Even schwifty!:wink: What you are saying is that I need a reference? Like in the picture below? Because what is connected now is a target from the CastTo BP_PlayerPawn.
I just fixed everything with events but I still don’t understand what I was doing wrong.

So, I cast to object A to get a function inside it, pass a reference to itself and then use that reference inside the function? Seems redundant. I tried but I get the same error. I guess it is one of those things I will understand later.