Access violation D3D11CreateDevice


I uninstalled visual studio 2013 pro, and installed 2015 community.

Then I uninstalled UE4 4.9 and installed 4.10 from marketplace.

When I tried to launch engine it crashes immediately.

I uninstalled 4.10 from marketplace and downloaded source code and compiled it with no error, and also it crashes as soon as I run it: “Fatal Error! UE4 Editor will now close”.

I launched engine from visual studio and it led me to an exception as shown in attached image.

4.11 preview 1 has same issue, and 4.9 is not working anymore.

I have a laptop with 24GB RAM, quad core i7, and a GTX 860m.

There is no project, I am just trying to open engine, I am not even getting to create project window.

I reinstalled 2013 professional side by side to community 2015, issue still persists

I also updated my Nvidia driver (clean install), and installed windows 8.1 SDK but nothing have worked so far.

I was able to run it when if select run with Intel HD graphics. But, If run with nvidia gpu, I get Access violation executing D3D11CreateDevice.

I attached DXDIAG.txt file.
link text

Any ideas?

Hey Night Watcher-

Do you have 4.11 preview through Launcher installed? If so you will need to uninstall prerequisites and then install 4.10. Can you also post full error message when trying to open editor? Are you able to install/run 4.9 or does same issue occur?


Well, error message did not give any information at, it crashes at 0% of loading, it is hard for me to provide a screenshot now, but it gave no information about error.
issue from code is that it was not able to identify GPU.
If I run UE4 using integrated intel GPU, engines runs fine.
I was able to make engine run by disabling my integrated GPU, and only then engine was able to recognize nvidia gpu. It is a temporarily fix, and I cannot keep using just dedicated GPU, it kills my battery life.
I uninstalled multiple engine version and installed new one, and they did not work, not 4.10.2 not 4.11 and not 4.9, even though 4.9 used to work. Only 4.10 was installed from both marketplace and github, all other where installed using marketplace.
I updated all my drivers, performed clean installation nothing worked.
My guess is that something on my computer made detect GPU function not work properly, which is first thing engine try to run when it starts

Hey Night Watcher-

Are you using a GPU switching software such as Nvidia Optimus? If not I would recommend getting this as it will handle switching between graphics cards seamlessly based on software applications running.


yes I am using Nvidia Optimus, and use to work fine, I’ve been using UE4 since version 1

Can you tell me if drivers for both cards are up to date? Intel integrated cards have been known to cause freezes/crashes when not using correct driver. There is more information here:

Please try to manually update Intel drivers manually as described in link and let me know if you still get same error when launching editor.

I went to intel website and downloaded latest driver fro windows 8.1 for my 4600 HD graphics, and it did not work. Also, why this question has been marked as resolved, when it’s not?

Hi NightWatcher,

It was marked resolved because you used “Answer” section for your comment and when Staff comments on an Answer, it auto-resolves. I’ve converted it to a comment to avoid further confusion.

Anyways, can you send me either a screenshot or text copy of error you are receiving? Is there anything else to error than “Access violation executing D3D11CreateDevice”?

EDIT: Also, what is your Nvidia Driver version (it does not say in dxdiag as current GPU when it was captured was Integrated Graphics)? If it is 361.43, could you revert to 359.06?

I’m really sorry, but I am currently overloaded with work, and cannot modify my drivers now, I will send you requested information in a few days

Hi Night Watcher,

We haven’t heard back from you in a bit, so I’m resolving this post for tracking purposes. When you get a chance to follow 's recommendations, let us know what happens if you’re still experiencing this problem and we’ll continue assisting. Thanks!