Accepting svn SSL certificate

When trying to connect the unreal editor to a svn repository I get the following error:

Error svn: E230001: Server SSL certificate verification failed: certificate issued for a different hostname, issuer is not trusted

I’d like to accept the certificate regardless of the different hostname. Is there some way to do this in the editor? If not, is there some workaround to do this?


I came across this issue while I was developing the UE4 SVN plugin and unfortunately the usual workaround I found was to update the servers certificate. The other option is to access the server via the hostname that the cert was issued for, as this sometimes occurred when accessing via IP, when the server had its cert issued to a domain.


Hmm, ok. I’m just thinking, could I also copy the certificate I get from the server by connecting by other means (e.g TortoiseSVN) to the correct folder for ue4? Do you know where the certificate has to go?

The issue is not one with your machine or your setup, but with the server itself. The certificate has been issued to a different server (or this server when it was called something different) and now this server is trying to use it. This means that SVN will not allow connections to this server because it is not trusted - it is masquerading as something else, which is a huge security risk.

As mentioned above, you have a number of options:

  • If you are able, contact the admin of the server to get the certificate upgraded. If the server is on your local domain then this is very straightforward, as the server can self-issue its certificate.
  • Connect to the server via the hostname that the certificate was registered to. This is only going to be useful if you are currently connecting via IP and the cert was issued to a hostname (or vice versa).
  • I haven’t tried this, but you may be able to simply connect to the server via Tortoise, accept the large warning dialog that pops up and continue to work in the Editor. Not holding out too much hope however.