Download

About to have a mild aneurism :P - Adding keyframes

Hey guys! So I’ve been barely getting any time to hop into UE, but every time I do it’s me trying to figure out why my frame poses are not saving properly. It sounds weird but I have screenshots.

So, I downloaded the Control Rig Mannequin asset to work out some extra animations and play a bit. I made something before I looked into documentation that made me laugh, but I was using the sliders/direct values of the XYZ transform and rotation on the controls on the rig. I found out that you can actually edit the mannequin in the editor window and add frames. I was like “oh duh”

Well, ever since that revelation, I have been just trying to start my own animation… and the first thing I edit and add a frame for bugs out? Or maybe I’m missing something.

In the first photo, you can see that I have moved the hand out of the default T pose position into my desired location, and I have the control for the right hand selected for this movement and rotation.

In the second photo, you can see that the right ***foot ***moves instead, and the hand snaps back to it’s default position, and you can also see that a frame was added to the right foot control in the sequencer.

The same seems to have happened when I try other controls, such as the left hand snaps the left elbow instead. What am I doing wrong?

I found a workaround by using the Autokey feature instead of applying keys with the S hotkey.

UPDATE: So, I’ve been losing my mind and still no answer to why this BS is happening, but when I select the RightHandCtrl in the sequencer, and then move what was selected in the editor window, I see the RightFootCtrl values changing!! It’s like all of the damned controls are linked to the wrong control in the sequencer by default! None of the videos have this issue, I have this problem on both my laptop and desktop, both of which are 4.25.4, and I have reported a bug because there is no other logical answer in my brain.

When this type of stuff happens while you’re learning, it is absolutely devastating when you don’t have an answer or time to figure out if it’s you or the program. I’m 100% convinced at this point it’s the damned engine.

https://youtu.be/dHoHu6sGiU4 A video about what I’m experiencing. Thanks in advance.

Have you tried 4.26? Control Rig was beta in 4.25 and was supposed to have more bug fixes and features in 4.26. I haven’t kept tabs on it but worth check to see how the latest one works.