About input

Player controller must be consuming the input. Select the input node and then disable Consume Input in the details panel.

If I put input such as(G key)into a playercontrollerBP,it will work,but if I put it into a custom BP or a playercharacterBP,it never gets fired…Please help me thanks.

Thanks for your reply,but it seems no use for me.But finally I have found that I need to uncheck the block input in the PlayerControllerBP and that works!