Download

A single sliding door is perfect, but two sliding doors go jitter!

Well, last night the Collective proved very helpful, so here I am again!

I followed the Blueprint Automated Door Tutorial found here and got it working without issue. It’s pretty simple, create a blueprint containing a doorframe and door meshes, a timeline with a float track and a couple of vectors for the door Start and End positions. No problem.

My particular sliding door has two doors sliding in opposite directions. (Think Blast Doors, Cargo Bay doors, whatever your sci-fi flavor is). I assumed it would be simple enough to modify the blueprint by adding the second mesh (for the other half of the door) and either creating a second timeline or having the first timeline fire two separate SetRelativeLocation.

With one door, the blueprint works normally. As you approach, door opens; back away and it closes. With the second door, the doors will open to ALMOST their target point, and then jitter back and forth (an oscillation of like 5-10%), as though the End Location target is impossible to reach. I tried using a seperate timeline for each door. I tried firing two Set RelativeLocations off of the same timelin. I tried introducing sequences to both of those variations, just to see what happens (same result).

The only instance where the doors don’t jitter on opening is when I disconnect the OnComponentEndOverlap. This feels like it might be part of the solution, but I can’t imagine why. That is where I have left the event graph for the moment, posted below.

Thanks in advance!

So, I looked at the tutorial and I think I know what is happening. In the tutorial it says, “9. Before leaving the Timeline Editor, make sure to check the Use Last Keyframe? checkbox. This will keep the Timeline from calculating beyond the end of the final keyframe, which would give you several seconds of dead animation after the door had opened.”

I do not believe that is correct and according to Unreal Documentation, if not checked, “If this is not active, the last keyframe of a sequence is ignored. This can help prevent skipping when an animation is looping.”

Change your timeline length to the actual length you want. Don’t leave it at 5. See if this helps.

Thank you for the suggestion. I have just tried that, as well as variations of checking and unchecking the Use Last Keyframe box one one or both timelines. The results remain the same.

EDIT:

I seem to have solved the issue by deleting the trigger volume and re-adding it. I likely clicked something on the original trigger at some point during the blueprint construction.

You should also get rid of the second timeline and just have them both run off the same timeline.

OK to have a set of double doors that each slide open in opposite directions, you need to do as I’ve done in the screenshots, you’re welcome :slight_smile:
I will try and get a video tutorial up soon showing how I (eventually) managed this! (Manim8 on YT)
Although seen as this post is from 2016 I will assume you’ve solved it, but for anyone who is still looking here for an answer, here it is!
You need to set up ONE Timeline, with 2 Vector graphs inside it. One for each door (DoorSlideR and DoorSlideL). Then enter the transform values as appropriate. Also have a Variable set up for each door with the Open value stored in it. From the Timeline, use Setters to set the new locations. Then put the Event graph together as below.