Download

A silly approach to dealing with UV Lightmap problems

I don’t know if this method (if you can call it a method:P) has been posted before but I couldn’t find it in any search results. Yesterday, I had some huge problems about the lightmap of a model I made. And just for the heck of it, I tried a silly thing if it works. And well, it worked! I still don’t know how this is possible but if anybody out there that has some problems about lightmaps, shadows etc. just try this silly method. Maybe it will work in your project too.

All I had done was moving the UVs out of main UV window in maya (in UV Texture Editor). So that the UVs will be seen as blank in Unreal. But the model has the same UV settings that it has been in Maya. Strange. Anyone who has an explanation I’d like to hear it!

70dd2a1ee4c79e4e7dff60715e291dbbd9d6d14b.jpeg

269d89a7bd6aaccfcfcb93a4cad521ee87eb189d.jpeg

I think what is happening is that, when you move your light map UV from the space its then reverting to your texture for the lighting. I didn’t do a uv map for my lighting and only had my texture uv map and it didn’t show any black parts either.

Yes it looks like its down to the UV lighting. In my project I am using some Medium poly assets. For stationery objects lightmap uvs are essential and U4 can build them for you. With dynamic and movable objects you need to focus more on the lighting technique/type as dynamic lighting is much more costly but can be essential for project like these for spaceships which are moving.

Here is a shot of mine, I am using distance field shadows :

68b77781a89c52610dd5233f0634dce4dd9814d6.jpeg

Hey looks great! I didn’t change any shadow options in the scene. It is right now what it is to come with a new map. This distance field shadow is better for big environments? Performance and quality vise?

I find distance fields better for my project, but its all down to testing. Look into Distance Field shadows if you have not used them, there will be some setting up of your meshes and lighting per scene with this method.

Ok thanks! I’ll try it.

Im pretty sure this method just removes lightmaps from the object.

i had the same problem, check this topic: Light/Shadow Issues - Rendering - Unreal Engine Forums

I’ve been having problems with lightmaps as well. getting strange shadows even though my UVs aren’t overlapping and are correctly spaced over the 0-1 space. I had to bump the lightmap up to 128 and on one mesh 160. others are fine at 64. if anyone knows what the hell is going on with this please let me know.

When you bumped the lightmap to higher values did it work, is it fine now?