Download

A problem with Unreal Engine 4 games. (update: not UE4 games)

Hello there.

This issue has been bothering me for months now. There are certain games I for some reason can’t play. I’ll give you the full list of those games here:

  • Rocket League
  • Blacklight: Retribution
  • Ghost Recon: Phantoms
  • American’s Army Proving Grounds
  • Dirty Bomb
  • Hearts of Iron 4
    I never understood what the problem here was. But I knew they had something in common. Most of the games I have on steam, and when I try to launch them, one of the following things always happens:
    1: Steam tries to start the game, it launches, runs (nothing starts), 1 second later it Synchronizes, then just stops.
    2: If games make it through the launching progress, it gives a DirectX error or something related to the topic.
    It’s always one of these two. Number 2 always occurs if the game has a specific launcher, like Blacklight Retribution (Arc).

So I never understood why this happened. It’s weird, because I’m using this laptop for quite a while. This problem never occurred to me before, until I reset my laptop a year back. Since then, these games didn’t work anymore.
But after alot of (online) research, I’ve finally cracked the code. I found a link between most of these games. They all run on Unreal Engine 4. I started noticing this problem after I installed Dirty Bomb. I thought, ‘’****, I hope this works…’’ and it didn’t. I thought maybe it could be because it runs on a certain gaming engine? I found out that it runs on UE4, and then I checked the other games who have the same problem and I saw that they use UE4 too (not sure about HoI4, but it seems to be the same problem I’m not 100% sure).

Now I googled this a **** ****ing lot, spent 100 hours on it or something but I just couldn’t solve it. Couldn’t do it! These are the things I tried:

  • I reinstalled DirectX
  • sfc /scannow in RUN after starting it as administrator
  • Restarting my PC 100’s of times
  • I have the most recent version of Microsoft Visual C++. They said downloading + installing 2010 would do the job, but I can’t because I have the most recent version already…
  • Adding to that, I tried installing the files manually, but I couldn’t because of some strange reason (talking about files like msvcp100.dll etc, maybe some of you know what it’s about now?)
  • Verifying my game files on steam, running steam in windows xp compatibility mode, running steam as admin, running the game file’s .exe files separately bla bla bla etc.
  • And some other stuff I probably can’t remember
    Resetting would be the ultimate solution but I’m not considering this just yet. There must be another way! Please, help! I’m very desperate…

I did not know where to post this issue, so I posted it here, on this forum. I mean, it’s the UE forum, the source of what I believe is the cause of my problem. I really hope some of you can help me out!!!
My laptop is the HP Pavilion 15-p142nd, if that helps.

Thanks alot,

  • Marty

None of those games run on Unreal Engine 4–they either run UE3 or a completely different engine. Ultimately you’ll have to contact the developers to see if they can help you. Since the issue is with different engines then I would guess it’s something with your PC rather than any specific engine problem.

No, no, I just made a mistake, I mean UE3 instead of UE4. I’m 99% sure that it has something to do with UE3, as I can’t run the games that run on this engine, and I can run any other game that runs on another engine just fine.

If you guys need some extra information about the errors, my computer information etc just tell me.

Only Rocket League, Blacklight, America’s Army, and Dirty Bomb are UE3. Hearts of Iron IV and Ghost Recon: Phantoms use proprietary engines.

Yeah that’s correct. I said ‘‘most’’ of the game. But the same error occurs. It’s not 100% UE3’s fault, but I assume that UE3 uses some technique which affects my PC somehow.
I’ll post more details of my PC info and the errors when I’m back home in a few hrs.

There’s no special insight that anyone in this forum is going to be able to uniquely provide, this is not related to UE4 at all. Try gaming and PC forums.

I remember something like this on a game I worked on and the fix was to install the directx 9 devkit - might be worth a try.

You can install it with the new one.
It won’t overwrite it. It will actually add just another version so if the program uses it… It can use it.

So go download it and install. And try Anadin’s suggestion as well. (It won’t overwrite anything either.)

EDIT: Looking over your post, you said something about msvcp100.dll.
It’s for sure Microsoft Visual C++ related. So go and install the ‘2010’ version!

Well I mean, I know, but I figured that it might be smart to ask it on the UE forum because I suspected that the UE engine was a source of the problem. I simply hoped that because u guys probably work with the engine, maybe someone could help me with some knowledge… I don’t think I’ll get luck somewhere else.

Thanks for the reply, I’ll surely try this! I’m downloading the DXDSK now, but its 500mb, so I’ll let you know if it worked.

I’ll try and download the most recent version. About the 2010 version, that’s not possible. Somewhere deep on the internet I found a reply on a topic, saying that you had to do it manually, but I’m not sure how to do that as it gave an error. I’m not sure what error it was, but I’ll post it together with some other information that might help you solve the problem.

Thanks for the help guys, if you need anything… Ask!

EDIT: I tried to install the devkit of DirectX, but ít said I could not install it because I already had it installed. It gave the error of this link: S1023 error when you install the DirectX SDK - Application Developer | Microsoft Docs
Should I remove DirectX as said in the link, and re-install it?

EDIT2: I couldn’t find the MVC version, only the update so I installed that one, but that didn’t work. Where can I find the full, downloadable version? Is it even out there?

So yeah I went back and looked at the installer stuff we did and the reason for needing the old DX was for a bunch of profiles for older cards etc. Unfortunately yeah you may have to do the installer dance.

And yeah we installed,
DX 9 sdk June 2010
VS2010SP1
VS2012U4

I assume there are newer VS’s these days.

I tried an MVS update, DirectX 2010 re-install (the devkit one), and some other stuff but it didn’t work.
So I went ahead and googled the errors I was getting (0xc000007b) for the 100st time. This time, I think I got something.
My problem is quite nicely explained here: Windows 10: Error bij het opstarten van LoL (0xc000007b) - Windows Clients - GoT (this is in dutch, maybe translating the page will help)
So now I’m being redirected to this topic: http://forums.euw.leagueoflegends.com/board/showthread.php?t=2031772&page=5
They also spoke about the problem with the MVS files I was speaking about earlier. He got the same problem about not being able to replace one of those files. One replied that having to do that was highly unlikely. But maybe that’s the problem?
Moving on, I’m now trying to completely remove DirectX9 (d3dx9_xx.dll files in system32 and syswow64 maps in Windows) and reinstall DirectX9, cuz apparently that works. If that doesn’t work, the problem has to be the .dll file thing with MVS. I’ll try the directX thing and post the results later. If that doesn’t work, I’ll try the .dll file thing and ask you guys for help to bypass the errors. If nothing, really nothings works, then I think I’ll remove my DirectX and Microsoft Visual Studios++ and reinstall it entirely, if that’s possible?? And before I **** up by removing the d3dx9_xx.dll files, is doing that safe?

This is the visual C++ you want in case you got the wrong one. https://www.microsoft.com/en-us/download/details.aspx?id=5555

Just try installing dx9 instead of uninstalling it. IF that doesn’t work… Look it up online on how to reinstall it correctly.

Don’t remove those files right now either.

The first one didn’t work. About DirectX, I have DirectX11, when I reinstall DirectX9 (which sounds weird considering I have DX11, but ill go with it), will I keep my DX11 files?

Yeah you do, the problem (if its what we saw) is that DX11 is missing some older data file that used to ship with DX9 and we had to include them in our install for slightly older hardware.

Okay, but how exactly do I reinstall DirectX9 properly? I searched google, but it seemed quite complex and I don’t really wanna make things much worse…
Here’s my DXDIAG if it helps: ------------------System Information------------------ Time of this r - Pastebin.com

Use the file at this link: https://www.microsoft.com/en-us/download/details.aspx?id=34429

This should not ruin anything. Just download and install.

Says I can’t download it as I don’t have Windows 98, 2000, or XP, something like that.

Try this instead? Download DirectX End-User Runtimes (June 2010) from Official Microsoft Download Center

And here is a tutorial for it: DirectX 9 and Direct Play on Windows 10 (You don’t need to do the last one about directplay.)

Sorry for the very late reply, you probably left the forums, got kids, a family, a job, and grew old already.

But I’m afraid that didn’t work as well. I’m starting to think that there’s something wrong with my laptop (which is weird, because before the laptop reset, it worked) which can only be solved with another full reinstall… But I really wanna avoid that so if any of u guys know another fix, then that’d be really really great. If u guys need some more information or fixes I tried, I’ll try and find them and explain as much as good as possible.