A list of mobile preview errors?

I recently started a blank project, where I noticed, that some functions do not work inside the editor’s mobile preview, but do work on ‘normal’ preview:

-drawing a text/material
-joystick (lefvirtualjoystickonly preset) does not work according to the blueprint

Are there any other differences? Or what am I missing?
Please help!!

Howdy andras2014,

Thank you for posting you issue here. Would you be able to attach your DXdiag to this post. Also, What version of UE4 are you currently using? is this version a Binary or Source build?

Any additional information would be greatly appreciated.

Thanks and have a great day!

Thanks for your help.
I am using the latest version of the unreal engine 4.5.1. (I am sorry, but I can’t answer if this is a binary or source build…)
The issue with draw text/material came up first at the third person blueprint template, where I created a hud, then I connected the event recieve draw hud to draw text.
However it didn’t work on an empty project either.

It seems that I couldn’t post everything about my dxdiag, please find it under this link:

For the Binary or Source issue, Would you be using the launcher version of UE4 or did you build the Engine from GitHub?

I use the launcher version of UE4.

Hey Andras2014,

So i have been looking into your issue and testing a few things out and i have a few questions. When you talk about the mobile previewer and the joysticks, is the error that you are seeing causing the mouse cursor to disappear?

Also, Could you clarify a bit more about the drawing a text.material? I am a bit confused as to how i may be able to reproduce this issue.


So, I retested everything and this is what I ended up with:
-Firstly, the joystick works finally according to my blueprint. I changed initially the leftvirtualjoystick preset to look around instead of walking around looking only in one direction (which is the default one, as far as I know).
What I am trying to say is that the joystick did work according to the default settings, even though I changed it.
Now, after restarting everything multiple times, it does what it should. (I did not forget to compile and save before I tried anything.) So this problem seems to be solved.
-Secondly, the other problem is about the ‘draw’ expression. As I have already told you, I use the event receive draw hud and draw text with custom font. The material I was trying to show was a copy from the content examples, from the blueprint hud template. To be more specific, it is a simple health bar.
-Concerning the mobile preview, I have never seen a mouse cursor inside the window.
Please find the bugs enclosed:
(for the first 2 pictures I use only a draw text)

Hey Andras,

I have just set up the issue of the text not showing on mobile preview and i have not been able to recreate the issue. Here is my current setup:

HUD Blueprint:

GameMode Blueprint:


Please let me know if any additional steps need to be taken to repro this issue.

Hi Sean,

I really appreciate your help, but that was the same setup I was already using. Here you can see the pictures that I have taken by playing it.

First picture: “Selected viewport” - the only mode where the ‘draw’ works.
(For the Material I have chosen a chrome preset, it is not important right now.)
Second picture: “Mobile preview” - not working
Third picture: “Standalone game” - it turns out that it does not work there either.

This is the second one.

One more thing: I don’t know if this is helpful, but playing the game in mobile preview I do not see the string “success” printed on the hud with this setup seen on the picture.
However I can use “print string” from another actor, like my character. So the print string works in itself.

I am not able to see any of the errors that you are currently running across. Here is a photo of what i am seeing when I change place the print string into the graph:

Would you still be seeing the errors when using the 4.6 preview version of UE4?

Could you tell me where do I find the settings to change the preview version?

If you are in the Launcher and select the Library tab, at the very top of the launcher, you will see the Add Engine + button. Go ahead and click that to create a new engine slot, There should be a little arrow button next to the version number and from there you can download the preview. This will create the 4.6 preview version of the engine.

When it is done downloading, be sure to open a copy of the project and not convert in place.

I have tried the same setup with unreal engine 4.6.0 preview, but there is no difference between the 2 preview versions. I couldn’t make the draw text appear on the screen.
(It works only in “selected viewport” only.)

In the meantime I have also tried to change the font, but that did not solve the issue either.

Hey Andras,

Thanks for the update. I have just tried to recreate the issue once again from a blank template and i am still not able to recreate the issue. There are 2 things that may help out the issue. You can send me an example project where the issue is occurring so that i may be bale to see what is happening on my end. You can send that to me privately through the forums. Here is a link to my page: https://forums.unrealengine.com/member.php?4890-Sean-Gribbin.

Or, you could uninstall UE4 entirely and then re-install it and they may help to solve the issue. This would provide a fresh install of the Engine.

If you do send me the project and the issue is not occurring, I am probably gonna ask you to uninstall and then re-install the engine anyways, so this may be the choice that you want to go with first.


Hey Sean,

Thank you for your support. Re-installing everything has solved the problem. “Draw text” on hud works finally, I am going to check “Draw material” later.

The draw material appears on the screen as well.

Howdy Andras,

Glad to hear that the issue has been resolved. If you do run across this error in a future release of UE4, please feel free to reopen this issues so that I may further investigate.

Thanks and have a great day!