A friend i want to learn unreal engine we have a problem using git

So the past 2 days i have been attempting setting up git for our game, so far i have not been able to get it working, the only thing added to the game so far is the 1st person shooter template generated by UE4 c++ blueprint also added a .gitignore file which includes the default visual studios and the suggested ignore list found here How do i sync project files with our Team - AnswerHub - Unreal Engine Forums yet i can’t seem to create the files on my desktop then sync git on my laptop and run the project successfully there?

here is our repo https://github.com/JAT-Entertainment/Desert_game

Hi JshReaper,

I have a few questions for you to try to figure out how you set up your repository, and how to get you up and running.

  • Did you create your repo initially on GitHub, or was it created locally on your desktop?
  • If you created it on GitHub, did you clone the repository to your desktop?
  • If you created it locally, did you sync to your repository on GitHub?

Looking at the commits in your repo, it looks like you were able to successfully add project files to the repo, though they were subsequently removed. If you could outline everything you have done so far, that would be helpful.

well i just started over from the beginning now (saved the project files elsewhere) so the repo will be totally clean, i did create it on github, successfully cloned it to my desktop, the problem is when i start either visual studios or UE4 (on my laptop) i get errors that some files are missing and the project could not be started.

I tried again to reproduce the issue that you described, but was unable to do so. Here is what I did.

  • Created a new repository on GitHub.
  • Copied the .gitignore file that you have in your repo and placed it in mine.
  • Cloned the repo to my computer.
  • Created a new code project and copied that project to where my repo was located.
  • Committed the project files into the repo.
  • Synced my local repo to the repo on GitHub.
  • Verified everything had been synced to GitHub.
  • Deleted my local copy of the repo.
  • Cloned the GitHub repo to my computer again (to simulate cloning the repo to a different computer).
  • Right-clicked on the .uproject file and made sure it was associated with the Engine installed on the computer (this regenerates all of the solution files).
  • Opened the project’s solution file in Visual Studio.
  • Built the project in Visual Studio.
  • Opened the project in the Editor.

Is that essentially the process that you have been following? What is the exact error message that you are seeing when you try to open the project on your laptop?

just tried going through the process you explained and got this error when pushing the files to github.

Hi JshReaper,

With regards to the errors that you were seeing, the Saved and Intermediate folders should be added to the .gitignore file. These folders are not necessary to be included in the repo. The Saved folder is intended to keep local save information, and the Intermediate folder gets rebuilt when project files are generated. Double-check your .gitignore file and make sure that it lists the following files/folders:


Hi , the problem seems to have been fixed now following your steps, also made sure those files/folders was in the .gitingore, thank you very much for the help.