A coupe of vehicle issues

hi,

ok so I am having few issues with vehicles.

first problem is lighting, every vehicle I make has really messed up shadows as you can see in these videos (ignore the models looks, they were just for testing;))

I thought it might be because of my UV’s but when I looked at the samples I found the sedan’s UV was unique and the truck had a 2nd UV, I tried making a second UV like the truck and it made no difference so I don’t think its my UV(although I couldn’t find a lightmap res setting for skeletal meshes), I also thought it might be my materials settings but they look the same as the samples, changing the type of lighting made no difference either, anyone know what is causing this?

problem 2 is that when you start driving the body of the car rises up and as you come to a stop it drops back down to where it should be, I looked at the template and sample and they both did it as well so I don’t think its my vehicle, it may be a bug.

problem 3 is the “wheel handler”, if you set up a vehicle the same as the vehicle template the wheels move smoothly but if you use the wheel handler instead they kind of jerk round when you first start moving and then start moving smoothly once your moving faster then a slow crawl, don’t know if its a bug or not.

if anyone knows anything about any of these things let me know, they’ve been bugging me for a while, especially the lighting thing (had that since the beta:p) so I would appreciate any help.

thanks:)

For lighting physics body bounds is the first thing that comes to mind, but i dont think that would be the issue here since you already have it set properly i believe. I also enable Inset Shadows in lighting properties of the vehicle, that also helps. And it’s not a UV issue, trust me. My car’s UV’s are sort of a mess and i havent had an issue so far. :stuck_out_tongue:

I’ve been having the second problem as well(i had also mentioned this in my thread.) I managed to minimize it at some point when i was playing with suspensions but then it started to become obvious again as i made more tweaks. Pretty annoying to see my Challenger rise up like a truck when it speeds up. :\

I think I am missing something, have no idea what, knowing me its probably something simple I’ve overlooked.

cars don’t usually do it in real life so I don’t know why they do in EU4, I still think its a bug.

I am adding this video as a visual of all 3 issues, although its quite hard to make out the jerking I mentioned.

That lighting issue with the wheels is so weird. Are all of your cars exported from the same software?

I also think that suspension raising is a bug, unless there is a default property we are missing like i did with center of mass offset. Hope Ori jumps in to enlighten us.

Btw, have you noticed something like this > my car is rear wheel drive. When i accelerate and then release the key the car starts to slow down but rear wheels start to rotate a lot slower(or faster) than they should be while the front wheels rotate and stop as expected. I tried this both on a box surface like your setup and a terrain and got the same result but strangely it gets fixed on a landscape that i scaled up after creation. I dont know if it is my vehicle settings or not so i’m not calling this one a bug for now. I should test it out with the sedan sometime.

The lighting issue on the wheels almost looks like the normals are backwards. Could you place the skeletal mesh of the car somewhere in the world and try to move some light around and see? I wouldn’t expect this to be a vehicle specific problem as again it looks more like the normals are flipped.

I’ll have to take a closer look at the suspension issue. It definitely looks like a bug. One thing you can do is bring up the debug window with the command showdebug vehicle. In this window you’ll see the suspension forces. If you’re driving on a flat surface the force graph should be flat. I’d be interested to know if there’s a sudden spike here.

Jacky, I’d have to see exactly what you mean for the rear wheel drive. However if I understand it correctly it sounds like it may be related to the differential of the wheels. Are you using rear wheel open or rear wheel minimum slip? If you use minimum slip the car’s differential will actually modify the amount the tires rotate. This is used when one tire is on ice, for example. I’m not sure if this is exactly the cause though I’d have to take a closer look.

UPDATE: Sorry I also forgot to mention that if you’re using rear wheel drive it makes sense for the back tires to spin more slowly as they are actually applying torque on the engine, which is still in some gear, while the front wheels are actually free to spin. I believe this is the correct behavior.

Hope that helps, please post more videos it helps.

Hi Ori!

It is open rear drive. Now that you mention it, it makes sense that rear wheels would act different than the front wheels, but it looks odd to me when it happens in this manner. Maybe my gear&torque setup is making it look so aggressive.

Here i’m not braking to slow down the car, and idle brake input is set to 0.

I checked the debug for suspensions, btw, and suspension force is flat while driving on flat surface but rising behaviour is still there.

hi Ori,

I flipped the normals and reimported to check but then the mesh looked inside out so to double check if it was the normals/model I imported it into UDK, set up a blank level with a single point light, placed the mesh in the level then moved the light around and the lighting was exactly as I expected it to be (the other light types worked fine as well), I then did the same thing in UE4 and the lighting was a mess, the front back and left side of the car’s body had almost correct shadows but the shadows on the roof and right side of the car’s body weren’t even close to how it should look, as for the wheels I have no clue what’s going on with the shadows. I also tried the other types of lights and had basically the same result so I am at a loss as to what’s going on with the lighting/shadows. I have made a video of this^^ to show the problem as clearly as possible.

Like jacky I also used the command, you can see what happened at the end of the vid, camstudio was actually working for once:).

Jacky,

I’d be interested to know what your torque/gear settings are. The vehicle debug window should tell you what gear you’re in when you’re coasting. There is a setting called Damping Rate Zero Throttle Clutch Engaged (and a few others) which determine how quickly the tire speed will match the engine speed. I do agree that the car seems to slow down pretty quickly, though I think the front and back rotation looks ok - my guess is it’s related to the interaction between clutch being engaged and the tires spinning freely.

Smokey, would you be able to attach your fbx here? I’d like to show it to someone here that would have more info about what might be going on.

Thanks for the info about the car suspension problem. I’ll have to debug this

If the rear and front wheels are spinning at different speeds, it means that one of them is slipping/skidding. When I use engine brake going down a hill, it may be the case that only the back wheels brake, but they still rotate at the same speed as the front wheels.

Spot on! It was Damping Rate Zero Throttle Clutch Engaged. I had set it to 4(default 2) for whatever reason when i was first playing around with vehicles then completely ignored it, not knowing what every parameter does what… But now i know better. :stuck_out_tongue:

Thanks Ori!

hi, sorry for the late response, internet was down. while I want to fix the lighting issue I don’t want to release the asset to everyone yet, would it be ok if I send you a PM with a link?

awesome:)

yeah sure, you can also e-mail me at ori dot cohen @ epicgames.com

I just though of another question. how do you stop the wheels going into meshes like this.

the car drives over it perfectly but if you drive into a mesh where the bottom of the wheels is not touching it they intersect, is there a way to stop this from happening?

We currently don’t support actual collision on the tires. This is something we’re working with NVIDIA to add. The case where the tires are very far from the body is more difficult as it really exposes this flaw. One approach you could take (we do this in the jeep sample game) is to add collision shapes to act as invisible fenders around the tires. This would be extra shapes added to the chassis of the car inside PhAT which you’d have to play with to get it so that it doesn’t hit the ground, but at the same time blocks these bad cases.

We are looking to improve this however so that you can actually get proper blocking behavior from the tires. Not sure how soon we’ll get this in though.

Hope that helps

ok, ill give that a try, thanks.

little update.

I got 4.3 and the shadows on my car are still wrong, so still stumped.

I also still cant get any usable collision for the wheels. I tried adding more collision shapes to the body but it didn’t work due to the gameplay I wanted. I then tried adding a collision shape the wheel hub bone, locking its movement except for the Z axis so it moved up/down when it collided with something but I couldn’t get the wheel to move with the wheel hub bone. I did think I might be able to make a semi-accurate collision for the bottom half of the wheel by adding 5 or 7 mini hidden wheels around the bottom of each visible wheel but I cant think of a way to make them all move up and down with each other (skeletal controls probably wont work), so they act as one wheel.

ok so final update, I think I’ve found the solution for the lighting and collision.

for the lighting I turned the “use TOA ref pose” option on in the import settings then I reimported and the lighting issue fixed itself, I have no idea why that fixed it:p

to get more accurate wheel collision I decided instead of trying to add or fake actual wheel collision I could just add more collision to the level.

here’s a vid of what it does now.

It’s not perfect (a bit more tweaking of collision mesh position needed) but I think it worked quite well:D

Glad to hear you finally fixed the lighting issue! And nice trick with collision. :slight_smile: More work than it should be but it looks a lot better now.

me too:)

thanks, it randomly dawned on me how I could do it, although I don’t think it will work very well for large convex angles.

Hi my friend

collision is very good
the Unity3D had this same problem! :mad:

I tried many ways but not as you collision

a4d0f70314657fa5ba9c1202078365693a6d4d9e.jpeg

Please tell me how can you fix this problem?

Thank you.