Download

a "Build lighting only" question, and how to get out of preview lighting.

I am wondering how i can build lighting to better preview what i am creating; as for me, my “build lighting only” option is grayed out.

There is no static lighting in the Ark branch of the engine iirc, so there isn’t anything to cook. By default the view port will show you the final lighting product, but you can mess with the video quality settings (same ones as in-game) and other things under the “show” menu at the top of the view port and in settings -> Engine Scalability Settings.

This is with their Global_PostProcess_Blueprint added. I guess once i cook the “preview”'s will disapear?

I think so! The little “preview” text everywhere, I believe, but don’t quote me on this; are there just during editing in the engine. I see this in UE4 when working on maps in there commonly.

Do you have “cast static shadow” disabled on your landscape?

Yep i do have it enabled. The lighting itself is a bit dark, but aside from that, it looks great with the acceptation of the “Previews”'s.

Static lighting gets ripped out on build times, the lighting won’t be there when you play it in-game I believe. Disable static shadows on your landscape and that should get things working for you.

Yeah indeed, you’ll want to disable Cast Static Shadow on any of your Lights. Static Shadowing isn’t ultimately supported in ARK (wasn’t super useful for a dynamic day/night cycle :wink: ).

Thank you! Been wondering why I couldn’t build my lighting!