5.4 Removed Post Process Material settings (Before Tonemapping)

It seems all my Post Process materials are broken in Unreal Engine 5.4, as this version has completely changed the blending options and removed the Before Tonemapping option in previous versions.

I saw a few posts about this issue, but none had good photos. I see no mention of this in the 5.4 release notes and the official 5.4 documentation still mentions the old options for Blendable Location.




In Photo 1 you can see what my sky used to look like. The sunset glow, which was being created by my post process material, appeared nicely in front of the clouds.

In Photo 2 you can see what happens when you open the Sky in 5.4. It is now set to “Scene Color After DOF” and the Translucent objects all appearing to be rendering in front of my post process.

In Photo 3 we can see some of the problems are fixed by using “Scene Color Before Bloom,” however the colors are way off and some things like the sun glow are now moved higher in the sky and not in the right place.

Photo 4 is closer with the colors, although a bit overexposed looking. Also all Translucent objects have disappeared entirely.

3 Likes

ughh this is killing me man, every toon outline tutorial I follow that uses versions before 5.4 has that “before tonemapping” and now I can’t follow because I can’t get a setting that will give me an exact similar result.

1 Like

(post deleted by author)

I actually found a pretty good fix for this in the meantime! It’s not a perfect solution but it’s been a “good enough” one for me. I won’t mark it as a Solution but I hope it helps…

The best new replacement for “Before Tonemapping” does indeed seem to be the “Scene Color Before Bloom.”

However, for me, the colors and many post process effects seemed… off still. Turns out it had to do with a change to the way screen percentage works in 5.4 I went into Project Settings > Viewport Resolution > Default screen percentage mode for realtime editor viewports, and changed it to either Manual or the one about DPI. That centered all my post processing effects in the center of the screen again and not smushed off to the corner, and it seems to be pretty good.

Heyo Gents! thank you for the discussion here!
I don’t think we have the exact same problem as @SoStylized, however your post helped me realize that the post processor we have need to change the “blendable location”

before (too bright)

after (just right)

Now, we are still working through a number of other style issues (like the super noisy sky), but at least regarding colors, this setting change appears to work for our needs.

1 Like

For days i thought it was someting i was doing wrong. seems i am always trying to do whatever is broken on each engine version

1 Like