5.1 Material Editor Preview All Black for One Project

What might be causing this issue? The Material Editor preview window is all black for all materials for a specific project.

See attached image, with left side showing the editor from a new 5.1 project, with a material created today with default settings, and the right side showing the editor from an existing 5.1 project, with a material created today with default settings.

Additional:
-No changes made to material after creating by right clicking in Content Browser
-Material is default Surface/Opaque/Default Lit
-Material Preview window is visible if I switch that window to Unlit mode (and Wireframe, and Optimization->Shader Complexity, but not, eg Detail Lighting or Path Tracing)
-Material works fine in an actual map in the same project.
-All materials in the problem project have this behavior, eg ones migrated from other projects, from Marketplace, and Material Instances

I’m having the exact same issue as you - works fine in unlit, but lit it’s just totally blank

+1 here lit black unlit ok

I fixed it - go to Window > Preview scene settings. Scroll down to environment and uncheck “show environment”

That fixed it for me

1 Like

That’s it!

Well, the fix for my project needed a step farther, with the environment setting plus lighting and exposure. Once I turned off “show environment”, I could see the preview mesh, but it was still all black, not red from the material. I checked “use sky lighting”, increased lighting intensity to 50k, and skylight intensity to 5k, and could see the mesh with a terrible looking red. So there just wasn’t enough light in the preview to illuminate the mesh. Then I set Exposure to Manual in the preview post process settings, and turned the light intensities back down to single digits. Thanks!

thanks,
1st workaround unchecking “show environment” works better, cannot see the background in the reflections but still see the floor and the shadows in normal light conditions

2nd tip works good as I can still keep my environment reflections and the sphere material, but I could not find any sweet spot to see both (the spere and the floor) in the same exposure value, floor stays still 100% black

I have the same problem, does any one know how to fix it or is this a EU5.1 bug?

Since:

  • Workaround is to modify preview pane settings until good enough,
  • I’d never used preview pane settings in any project until ThomasCoote recommended it
  • Somehow, on my one project, material preview was black
    …it seems like a 5.1 bug.

I filed a bug report last week, but haven’t heard back and don’t see anything related when searching issues.unrealengine.com

Also seeing this bug. But also for skeletal meshes:

For me turning off the background fixed most issues (guessing its something with the backgrounds exposure or something).
Try also switching between manual exposure (-1 or -2 or something) and then back to game settings, that fixed it to a workable state for me. Still not perfect though…

Turning off the skylight RT shadows in the project settings helped here.

2 Likes