5.1 bug. Renaming blueprint fails data validation with GameFeature plugin

When I rename my blueprint asset, it will fail data validation. Went back to 5.03, it doesn’t happen.

Repro (with GameFeature plugin enabled)

  1. Run data validation. Pass
  2. Rename blueprint.
  3. Run data validation. Fail. It is still keeping reference to old name.


When you rename a Blueprint asset, it can cause the references to that asset to become invalid, which can lead to data validation errors. This is because the Blueprint asset’s name is used as a reference in various places in the project, such as in other Blueprints, in actors, and in level sequences.

One way to resolve this issue is to use the “Find and Replace References” feature in the Unreal Engine editor. This can be found in the “Blueprints” menu, under “Refactor.”

You can use this feature to find all references to the old Blueprint asset name and replace them with the new name. This will update all references to the Blueprint asset throughout the project and resolve the data validation errors.

It’s worth mentioning that when you rename a Blueprint asset, it will not automatically update the references in the project, that’s why you need to do it manually.

It’s also good to mention that, when using the find and replace feature, you should make sure you have a backup of your project, in case something goes wrong.

I’ve fixed redirector already, I’m not new to unreal. The blueprint is not even referenced. It is keeping the old name in the uasset , which if do a text search within the uasset, and that’s failing.

Have you tried it in your project? It happens in 5.1, not 5.03.

I foundt the plugin causing it, it is Game Features plugin

AFAIK that is just typical UE 5.1.

When you rename a BP, you’re going to get that error. No problem. Compile + Save. Clear errors. Save again. Error should be gone.

No it doesn’t. Have you tried it? 5.03 doesn’t do that.

I work exclusively in Lyra 5.1 which uses Game Features. All of my content is in a GFP.

I literally see this validation error every single time I rename a BP. This process works for me to clear the error.

You try this repro

  1. Create a new Actor blueprint
  2. Save
  3. Rename it. Save. Do what fix director if you prefer.
  4. Run validation with dependencies. It fails.

Please tell me if this doesn’t have issue on your side. This doesn’t happen with my project in 5.03, which I verified with old copy. And I have tried on new projects as well.