Download

"405 Not Allowed nginx" error after forking

Hi there

After the repository of my fork went south, I tried to do a new fork but get the error “405 not allowed” for some reason. Is that an issue at Epic’s end or a GitHub thing?

cheers,
Michael

You can’t have multiple forks on github. You have to go to your existing fork and delete it before you can refork.
If you go to your fork on GitHub, on the right side will be a ‘Settings’ tab. You can delete your fork from there.

Alternatively, I believe renaming your fork will also allow you to refork, but I’m not certain.

Also if you delete your fork, and still get “405 not allowed” when attempting to create a new fork give it a minute and try forking again.

I didn’t have multiple forks. I deleted the old repo and tried to fork again - that should normally be possible.

As it turned out, the problem was with Github - they had a known issue on their storage system. Just got feedback from their support.